CVE-2014-4914
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle...
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
- Record
CVE-2014-4914- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
- Record
CVE-2014-4914- Updated
- 2026-11-02
EUVDEUVD-2014-4833 No score
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
- Record
EUVD-2014-4833- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4vqq-fg9c-w77h
9.8
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle...
The Zend_Db_Select::order function in Zend Framework before 1.12.7 does not properly handle parentheses, which allows remote attackers to conduct SQL injection attacks via unspecified vectors.
- Record
GHSA-4vqq-fg9c-w77h- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVMGASA-2014-0311 No score
Updated php-ZendFramework packages fix security vulnerability
The implementation of the ORDER BY SQL statement in Zend_Db_Select of Zend Framework 1 contains a potential SQL injection when the query string passed contains parentheses (CVE-2014-4914).
- Record
MGASA-2014-0311- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zendframeworkDebian:6.0 From an advisory covering 11 CVEs |
before 1.10.6-1squeeze3, plus listed versions 1.10.6-11.10.6-1squeeze11.10.6-1squeeze2 |
1.10.6-1squeeze3 |
zendframeworkDebian:7 From an advisory covering 9 CVEs |
before 1.11.13-1.1+deb7u1, plus listed versions 1.11.13-1.1 |
1.11.13-1.1+deb7u1 |
php-ZendFrameworkMageia:3 |
before 1.12.7-1.mga3 | 1.12.7-1.mga3 |
php-ZendFrameworkMageia:4 |
before 1.12.7-1.mga4 | 1.12.7-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-4914 is a critical vulnerability (CVSS 9.8) in Zend Framework, published August 5, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in php-ZendFramework 1.12.7-1.mga3.