Every CVE Search/ Get API key

CVE-2014-4986

phpMyAdmin cross-site scripting Vulnerability in Table or Column Names

3.5 LowFix available

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Exploit likelihood

1.60%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
CVE-2014-4986
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
CVE-2014-4986
Updated
2026-11-02
EUVDEUVD-2022-4418 No score

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
EUVD-2022-4418
Updated
2026-11-03
GitHub AdvisoriesGHSA-jqmr-wqgp-8mh2 No score

phpMyAdmin cross-site scripting Vulnerability in Table or Column Names

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
GHSA-jqmr-wqgp-8mh2
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
CVE-2014-4986
Updated
2026-11-02
OSVDEBIAN-CVE-2014-4986 No score

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
DEBIAN-CVE-2014-4986
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-jqmr-wqgp-8mh2 No score

phpMyAdmin cross-site scripting Vulnerability in Table or Column Names

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
GHSA-jqmr-wqgp-8mh2
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2014-0310 No score

Updated phpmyadmin package fixes security vulnerabilities

In phpMyAdmin before 4.1.14.2, when navigating into the database triggers page, it is possible to trigger an XSS with a crafted trigger name (CVE-2014-4955).

In phpMyAdmin before 4.1.14.2, with a crafted column name it is possible to trigger an XSS when dropping the column in table structure page. With a crafted table name it is possible to trigger an XSS when dropping or truncating the table in table operations page (CVE-2014-4986).

In phpMyAdmin before 4.1.14.2, An unpriviledged user could view the MySQL user list and manipulate the tabs displayed in phpMyAdmin for them (CVE-2014-4987).

Record
MGASA-2014-0310
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-4986 No score

Multiple cross-site scripting (XSS) vulnerabilities in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.1, 4.1.x before 4.1.14.2, and 4.2.x before 4.2.6 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) table name or (2) column name that is improperly handled during construction of an AJAX confirmation message.

Record
UBUNTU-CVE-2014-4986
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
4.0.0 up to 4.0.10.1
4.0.10.1
phpmyadmin/phpmyadmin
Packagist
4.1.0 up to 4.1.14.2
4.1.14.2
phpmyadmin/phpmyadmin
Packagist
4.2.0 up to 4.2.6
4.2.6
phpmyadmin
Debian:12
before 4:4.2.6-1
4:4.2.6-1
phpmyadmin
Debian:13
before 4:4.2.6-1
4:4.2.6-1
phpmyadmin
Debian:14
before 4:4.2.6-1
4:4.2.6-1
phpmyadmin/phpmyadmin
Packagist
4.0.0 up to 4.0.10.1, plus listed versions
4.0.14.0.104.0.24.0.34.0.4
Show 7 moreShow less
4.0.4.14.0.4.24.0.54.0.64.0.74.0.84.0.9
4.0.10.1
phpmyadmin
Mageia:3
before 4.1.14.2-1.mga3
4.1.14.2-1.mga3
phpmyadmin
Mageia:4
before 4.1.14.2-1.mga4
4.1.14.2-1.mga4
phpmyadmin
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1
Show 4 moreShow less
4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4
None known
phpMyAdmin
openSUSE:Tumbleweed
before 4.6.5.2-1.1
4.6.5.2-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-4986 is a low vulnerability (CVSS 3.5) in Phpmyadmin, published July 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in phpmyadmin/phpmyadmin 4.0.10.1.

References

Show 134 moreShow less
MoveEnter Open