Every CVE Search/ Get API key

CVE-2014-4987

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote...

4.0 MediumFix available

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Exploit likelihood

1.26%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
CVE-2014-4987
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
CVE-2014-4987
Updated
2026-11-02
EUVDEUVD-2014-4901 No score

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
EUVD-2014-4901
Updated
2026-11-03
GitHub AdvisoriesGHSA-pvp5-3q7r-jxp6 No score

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote...

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
GHSA-pvp5-3q7r-jxp6
Updated
2026-11-02
OSV No score

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
CVE-2014-4987
Updated
2026-11-02
OSVDEBIAN-CVE-2014-4987 No score

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
DEBIAN-CVE-2014-4987
Updated
2026-11-02
OSVMGASA-2014-0310 No score

Updated phpmyadmin package fixes security vulnerabilities

In phpMyAdmin before 4.1.14.2, when navigating into the database triggers page, it is possible to trigger an XSS with a crafted trigger name (CVE-2014-4955).

In phpMyAdmin before 4.1.14.2, with a crafted column name it is possible to trigger an XSS when dropping the column in table structure page. With a crafted table name it is possible to trigger an XSS when dropping or truncating the table in table operations page (CVE-2014-4986).

In phpMyAdmin before 4.1.14.2, An unpriviledged user could view the MySQL user list and manipulate the tabs displayed in phpMyAdmin for them (CVE-2014-4987).

Record
MGASA-2014-0310
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-4987 No score

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Record
UBUNTU-CVE-2014-4987
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin
Debian:12
before 4:4.2.6-1
4:4.2.6-1
phpmyadmin
Debian:13
before 4:4.2.6-1
4:4.2.6-1
phpmyadmin
Debian:14
before 4:4.2.6-1
4:4.2.6-1
phpmyadmin
Mageia:3
before 4.1.14.2-1.mga3
4.1.14.2-1.mga3
phpmyadmin
Mageia:4
before 4.1.14.2-1.mga4
4.1.14.2-1.mga4
phpmyadmin
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1
Show 4 moreShow less
4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4
None known
phpMyAdmin
openSUSE:Tumbleweed
before 4.6.5.2-1.1
4.6.5.2-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-4987 is a medium vulnerability (CVSS 4.0) in Phpmyadmin, published July 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.26%, the 69th percentile. Fixed in phpmyadmin 4:4.2.6-1.

References

Show 133 moreShow less
MoveEnter Open