Every CVE Search/ Get API key

CVE-2014-5012

DOMPDF denial of service vulnerability

6.5 MediumFix available

CVE-2014-5012 is a medium vulnerability (CVSS 6.5) in Dompdf Project Dompdf, published January 10, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 68th percentile. Fixed in dompdf/dompdf 0.6.2.

DOMPDF before 0.6.2 allows denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.23%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

DOMPDF before 0.6.2 allows denial of service.

Record
CVE-2014-5012
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

DOMPDF before 0.6.2 allows denial of service.

Record
CVE-2014-5012
Updated
2026-11-02
EUVDEUVD-2022-4917 No score

DOMPDF before 0.6.2 allows denial of service.

Record
EUVD-2022-4917
Updated
2026-11-03
GitHub AdvisoriesGHSA-q83c-64c9-c42m 6.5

DOMPDF denial of service vulnerability

DOMPDF before 0.6.2 allows denial of service.

Record
GHSA-q83c-64c9-c42m
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSV 6.5

DOMPDF before 0.6.2 allows denial of service.

Record
CVE-2014-5012
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-5012 6.5

DOMPDF before 0.6.2 allows denial of service.

Record
DEBIAN-CVE-2014-5012
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-q83c-64c9-c42m 6.5

DOMPDF denial of service vulnerability

DOMPDF before 0.6.2 allows denial of service.

Record
GHSA-q83c-64c9-c42m
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5012 6.5

DOMPDF before 0.6.2 allows denial of service.

Record
UBUNTU-CVE-2014-5012
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-6277-1 No score

php-dompdf vulnerabilities

It was discovered that Dompdf was not properly validating untrusted input when processing HTML content under certain circumstances. An attacker could possibly use this issue to expose sensitive information or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2014-5011, CVE-2014-5012, CVE-2014-5013)

It was discovered that Dompdf was not properly validating processed HTML content that referenced PHAR files, which could result in the deserialization of untrusted data. An attacker could possibly use this issue to execute arbitrary code. (CVE-2021-3838)

It was discovered that Dompdf was not properly validating processed HTML content that referenced both a remote base and a local file, which could result in the bypass of a chroot check. An attacker could possibly use this issue to expose sensitive information. (CVE-2022-2400)

Record
USN-6277-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dompdf/dompdf
Packagist
0.6 up to 0.6.2
0.6.2
php-dompdf
Debian:12
before 0.6.2+dfsg-1
0.6.2+dfsg-1
dompdf/dompdf
Packagist
0.6 up to 0.6.2, plus listed versions
v0.6.0v0.6.1
0.6.2
php-dompdf
Ubuntu:Pro:16.04:LTS
before 0.6.1+dfsg-2ubuntu1+esm1, plus listed versions
0.6.1+dfsg-20.6.1+dfsg-2build10.6.1+dfsg-2ubuntu1
0.6.1+dfsg-2ubuntu1+esm1
php-dompdf
Ubuntu:Pro:18.04:LTS
before 0.6.2+dfsg-3ubuntu0.18.04.1~esm1, plus listed versions
0.6.2+dfsg-3
0.6.2+dfsg-3ubuntu0.18.04.1~esm1
php-dompdf
Ubuntu:20.04:LTS
before 0.6.2+dfsg-3ubuntu0.20.04.1, plus listed versions
0.6.2+dfsg-3
0.6.2+dfsg-3ubuntu0.20.04.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 7 moreShow less
MoveEnter Open