CVE-2014-5191
The Preview plugin in CKEditor allows Cross-site scripting (XSS)
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2014-5191- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2014-5191- Updated
- 2026-11-02
EUVDEUVD-2014-5089 No score
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2014-5089- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v27h-j97p-wqmx
6.9
The Preview plugin in CKEditor allows Cross-site scripting (XSS)
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-v27h-j97p-wqmx- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-v27h-j97p-wqmx
6.9
The Preview plugin in CKEditor allows Cross-site scripting (XSS)
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-v27h-j97p-wqmx- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2014-5191- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-5191 No score
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
DEBIAN-CVE-2014-5191- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-5191 No score
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
UBUNTU-CVE-2014-5191- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ckeditor/ckeditorPackagist |
before 4.4.3 | 4.4.3 |
ckeditorDebian:12 |
before 4.4.4+dfsg1-1 | 4.4.4+dfsg1-1 |
ckeditor3Debian:12 |
All versions, plus listed versions 3.6.6.1+dfsg-7 |
None known |
ckeditor/ckeditorPackagist |
before 4.4.3, plus listed versions 4.3.34.3.44.3.54.4.04.4.14.4.2 |
4.4.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-5191 is a medium vulnerability (CVSS 4.3) in Ckeditor, published August 7, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 78th percentile. Fixed in ckeditor/ckeditor 4.4.3.