Every CVE Search/ Get API key

CVE-2014-5204

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different...

6.8 MediumFix available

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Exploit likelihood

1.85%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
CVE-2014-5204
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
CVE-2014-5204
Updated
2026-11-02
EUVDEUVD-2014-5102 No score

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
EUVD-2014-5102
Updated
2026-11-03
GitHub AdvisoriesGHSA-72g8-w2mw-jmg3 No score

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different...

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
GHSA-72g8-w2mw-jmg3
Weakness
CWE-352
Updated
2026-11-02
OSV No score

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
CVE-2014-5204
Updated
2026-11-02
OSVDEBIAN-CVE-2014-5204 No score

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
DEBIAN-CVE-2014-5204
Updated
2026-11-02
OSVUBUNTU-CVE-2014-5204 No score

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

Record
UBUNTU-CVE-2014-5204
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.9.2+dfsg-1
3.9.2+dfsg-1
wordpress
Debian:13
before 3.9.2+dfsg-1
3.9.2+dfsg-1
wordpress
Debian:14
before 3.9.2+dfsg-1
3.9.2+dfsg-1
wordpress
Debian:6.0
From an advisory covering 6 CVEs
before 3.6.1+dfsg-1~deb6u5, plus listed versions
3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-2
Show 21 moreShow less
3.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-13.3.2+dfsg-13.3.2+dfsg-1~squeeze13.4+dfsg-13.4+dfsg-23.4+dfsg-33.4.1+dfsg-13.4.2+dfsg-13.5+dfsg-13.5.1+dfsg-13.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-13.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u4
3.6.1+dfsg-1~deb6u5
wordpress
Debian:7
From an advisory covering 6 CVEs
before 3.6.1+dfsg-1~deb7u4, plus listed versions
3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1
Show 12 moreShow less
3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u3
3.6.1+dfsg-1~deb7u4
wordpress
Ubuntu:14.04:LTS
before 3.8.2+dfsg-1ubuntu0.1, plus listed versions
3.6.1+dfsg-13.7.1+dfsg-13.8.1+dfsg-13.8.1+dfsg1-23.8.2+dfsg-1
3.8.2+dfsg-1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-5204 is a medium vulnerability (CVSS 6.8) in Wordpress, published August 9, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.85%, the 79th percentile. Fixed in wordpress 3.9.2+dfsg-1.

References

MoveEnter Open