CVE-2014-5242
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22...
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22.x before 1.22.9 and 1.23.x before 1.23.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving the multipageimagenavbox class in conjunction with an action=raw value.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22.x before 1.22.9 and 1.23.x before 1.23.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving the multipageimagenavbox class in conjunction with an action=raw value.
- Record
CVE-2014-5242- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22.x before 1.22.9 and 1.23.x before 1.23.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving the multipageimagenavbox class in conjunction with an action=raw value.
- Record
CVE-2014-5242- Updated
- 2026-11-02
EUVDEUVD-2014-5140 No score
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22.x before 1.22.9 and 1.23.x before 1.23.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving the multipageimagenavbox class in conjunction with an action=raw value.
- Record
EUVD-2014-5140- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c6g2-67vp-v3m9 No score
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22...
Cross-site scripting (XSS) vulnerability in mediawiki.page.image.pagination.js in MediaWiki 1.22.x before 1.22.9 and 1.23.x before 1.23.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving the multipageimagenavbox class in conjunction with an action=raw value.
- Record
GHSA-c6g2-67vp-v3m9- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVMGASA-2014-0309 No score
Updated mediawiki packages fix security vulnerabilities
MediaWiki before 1.23.2 is vulnerable to JSONP injection in Flash (CVE-2014-5241), XSS in mediawiki.page.image.pagination.js (CVE-2014-5242), and clickjacking between OutputPage and ParserOutput (CVE-2014-5243).
This update provides MediaWiki 1.23.2, fixing these and other issues.
- Record
MGASA-2014-0309- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-5242 is a medium vulnerability (CVSS 4.3) in Mediawiki, published August 5, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.07%, the 81st percentile. No source names a fixed version.
References
lists.wikimedia.org/pipermail/mediawiki-announce/2014-July/000157.html
bugzilla.wikimedia.org/show_bug.cgi?id=66608
mandriva.com/security/advisories?name=MDVSA-2014:153
securityfocus.com/bid/69135
openwall.com/lists/oss-security/2014/08/14/5
advisories.mageia.org/MGASA-2014-0309.html
nvd.nist.gov/vuln/detail/CVE-2014-5242
github.com/advisories/GHSA-c6g2-67vp-v3m9
bugs.mageia.org/show_bug.cgi?id=13833