CVE-2014-6262
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core...
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
CVE-2014-6262- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-134
- Updated
- 2026-11-02
CVE List No score
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
CVE-2014-6262- Updated
- 2026-11-02
EUVDEUVD-2014-6148 No score
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
EUVD-2014-6148- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f8vh-3m24-38r6
7.5
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core...
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
GHSA-f8vh-3m24-38r6- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-134
- Updated
- 2026-11-02
OSV
7.5
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
CVE-2014-6262- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-6262
7.5
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
DEBIAN-CVE-2014-6262- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-6262
7.5
Multiple format string vulnerabilities in the python module in RRDtool, as used in Zenoss Core before 4.2.5 and other products, allow remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted third argument to the rrdtool.graph function, aka ZEN-15415, a related issue to CVE-2013-2131.
- Record
UBUNTU-CVE-2014-6262- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
rrdtoolDebian:12 |
before 1.5.4-1 | 1.5.4-1 |
rrdtoolDebian:13 |
before 1.5.4-1 | 1.5.4-1 |
rrdtoolDebian:14 |
before 1.5.4-1 | 1.5.4-1 |
rrdtoolDebian:8 |
before 1.4.8-1.2+deb8u1, plus listed versions 1.4.8-1.2 |
1.4.8-1.2+deb8u1 |
rrdtoolUbuntu:14.04:LTS |
All versions, plus listed versions 1.4.7-2ubuntu21.4.7-2ubuntu31.4.7-2ubuntu41.4.7-2ubuntu5 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-6262 is a high vulnerability (CVSS 7.5) in Zenoss Core, published February 12, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.25%, the 94th percentile. Fixed in rrdtool 1.5.4-1.
References
docs.google.com/spreadsheets/d/1dHAc4PxUbs-4Dxzm1wSCE0sMz5UCMY6SW3PlMHSyuuQ/edit?usp=sharing
kb.cert.org/vuls/id/449452
securityfocus.com/bid/71540
github.com/oetiker/rrdtool-1.x/pull/532
github.com/oetiker/rrdtool-1.x/commit/64ed5314af1255ab6dded45f70b39cdeab5ae2ec
github.com/oetiker/rrdtool-1.x/commit/85261a013112e278c90224033f5b0592ee387786
Show 7 moreShow less
lists.debian.org/debian-lts-announce/2020/03/msg00000.html
lists.debian.org/debian-lts-announce/2020/03/msg00003.html
nvd.nist.gov/vuln/detail/CVE-2014-6262
github.com/advisories/GHSA-f8vh-3m24-38r6
security-tracker.debian.org/tracker/CVE-2014-6262
ubuntu.com/security/CVE-2014-6262
cve.org/CVERecord?id=CVE-2014-6262