CVE-2014-6276
Roundup sensitive data disclosure vulnerability
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
CVE-2014-6276- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
CVE-2014-6276- Updated
- 2026-11-02
EUVDEUVD-2016-0031 No score
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
EUVD-2016-0031- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j556-q367-2gw6
5.3
Roundup sensitive data disclosure vulnerability
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
GHSA-j556-q367-2gw6- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-j556-q367-2gw6
5.3
Roundup sensitive data disclosure vulnerability
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
GHSA-j556-q367-2gw6- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-6276
4.3
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
UBUNTU-CVE-2014-6276- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVPYSEC-2016-33 No score
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
- Record
PYSEC-2016-33- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
roundupPyPI |
before 1.5.1 | 1.5.1 |
roundupDebian:7 |
before 1.4.20-1.1+deb7u1, plus listed versions 1.4.20-1.1 |
1.4.20-1.1+deb7u1 |
roundupDebian:8 |
before 1.4.20-1.1+deb8u1, plus listed versions 1.4.20-1.1 |
1.4.20-1.1+deb8u1 |
roundupPyPI |
before 1.5.1, plus listed versions 0.5.90.6.110.6.80.6.90.7.0 Show 45 moreShow less0.7.0b30.7.10.7.110.7.120.7.20.7.30.7.40.7.50.7.70.7.80.7.90.8.00.8.0b10.8.10.8.20.8.30.8.40.8.50.8.60.9.0b11.01.0.11.1.01.1.11.1.21.2.01.2.11.3.01.3.11.3.21.3.31.4.01.4.11.4.101.4.111.4.121.4.131.4.141.4.151.4.161.4.171.4.181.4.191.4.21.4.20 |
1.5.1 |
roundupUbuntu:14.04:LTS |
before 1.4.20-1.1+deb8u1build0.14.04.1, plus listed versions 1.4.20-1.1 |
1.4.20-1.1+deb8u1build0.14.04.1 |
roundupUbuntu:16.04:LTS |
before 1.4.20-1.1+deb8u1build0.16.04.1, plus listed versions 1.4.20-1.1 |
1.4.20-1.1+deb8u1build0.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-6276 is a medium vulnerability (CVSS 4.3) in Roundup-tracker Roundup, published March 3, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.55%, the 75th percentile. Fixed in roundup 1.5.1.
References
hg.code.sf.net/p/roundup/code/rev/a403c29ffaf9
debian.org/security/2016/dsa-3502
sourceforge.net/p/roundup/code/ci/tip/tree/CHANGES.txt
nvd.nist.gov/vuln/detail/CVE-2014-6276
github.com/pypa/advisory-database/tree/main/vulns/roundup/PYSEC-2016-33.yaml
github.com/advisories/GHSA-j556-q367-2gw6
github.com/roundup-tracker/roundup
ubuntu.com/security/CVE-2014-6276
cve.org/CVERecord?id=CVE-2014-6276
Left out here: 9 versions. The JSON record has them.