Every CVE Search/ Get API key

CVE-2014-6316

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running...

5.8 MediumFix available

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running under the web root, which allows remote attackers to conduct open redirect and phishing attacks via a crafted URL in the return parameter to login_page.php.

Exploit likelihood

2.33%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running under the web root, which allows remote attackers to conduct open redirect and phishing attacks via a crafted URL in the return parameter to login_page.php.

Record
CVE-2014-6316
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running under the web root, which allows remote attackers to conduct open redirect and phishing attacks via a crafted URL in the return parameter to login_page.php.

Record
CVE-2014-6316
Updated
2026-11-02
EUVDEUVD-2014-6200 No score

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running under the web root, which allows remote attackers to conduct open redirect and phishing attacks via a crafted URL in the return parameter to login_page.php.

Record
EUVD-2014-6200
Updated
2026-11-03
GitHub AdvisoriesGHSA-gr3x-2r26-g8jg No score

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running...

core/string_api.php in MantisBT before 1.2.18 does not properly categorize URLs when running under the web root, which allows remote attackers to conduct open redirect and phishing attacks via a crafted URL in the return parameter to login_page.php.

Record
GHSA-gr3x-2r26-g8jg
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mantis
Debian:7
before 1.2.18-1, plus listed versions
1.2.11-1.21.2.11-1.2+deb7u1
1.2.18-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-6316 is a medium vulnerability (CVSS 5.8) in Mantisbt, published December 12, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.33%, the 83rd percentile. Fixed in mantis 1.2.18-1.

References

Show 4 moreShow less
MoveEnter Open