Every CVE Search/ Get API key

CVE-2014-6393

No Charset in Content-Type Header in express

6.1 MediumFix available

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.14%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Record
CVE-2014-6393
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Record
CVE-2014-6393
Updated
2026-11-02
EUVDEUVD-2018-0603 No score

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Record
EUVD-2018-0603
Updated
2026-11-03
GitHub AdvisoriesGHSA-gpvr-g6gh-9mc2 6.1

No Charset in Content-Type Header in express

Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7.

Recommendation

For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.

Record
GHSA-gpvr-g6gh-9mc2
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Record
CVE-2014-6393
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2014-6393 6.1

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Record
DEBIAN-CVE-2014-6393
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 5 moreShow less
OSVGHSA-gpvr-g6gh-9mc2 6.1

No Charset in Content-Type Header in express

Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7.

Recommendation

For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.

Record
GHSA-gpvr-g6gh-9mc2
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2014-6393 6.1

The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

Record
UBUNTU-CVE-2014-6393
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVCLSA-2026-1792473577 No score

TuxCare security update for express (2 CVEs)

TuxCare rebuilt express to address 2 CVEs. Fixed in 3.1.2-tuxcare.1.

Record
CLSA-2026-1792473577
Updated
2026-11-02
OSVCLSA-2026-1793832892 No score

TuxCare security update for connect (1 CVE)

TuxCare rebuilt connect to address 1 CVE. Fixed in 2.12.0-tuxcare.3.

Record
CLSA-2026-1793832892
Updated
2026-11-05
OSVCLSA-2026-1793833558 No score

TuxCare security update for express (2 CVEs)

TuxCare rebuilt express to address 2 CVEs. Fixed in 3.4.8-tuxcare.3.

Record
CLSA-2026-1793833558
Updated
2026-11-05

Affected products

Affected packages

Affected packages
PackageAffectedFixed
express
npm
before 3.11.0
3.11.0
express
npm
4.0.0 up to 4.5.0
4.5.0
express
TuxCare:npm
From an advisory covering 2 CVEs
3.1.2-tuxcare.0 up to 3.1.2-tuxcare.1, plus listed versions
3.1.2
3.1.2-tuxcare.1
connect
TuxCare:npm
2.12.0-tuxcare.0 up to 2.12.0-tuxcare.3, plus listed versions
2.12.02.12.0-tuxcare.12.12.0-tuxcare.2
2.12.0-tuxcare.3
express
TuxCare:npm
From an advisory covering 2 CVEs
3.4.8-tuxcare.0 up to 3.4.8-tuxcare.3, plus listed versions
3.4.83.4.8-tuxcare.13.4.8-tuxcare.2
3.4.8-tuxcare.3
node-express
Debian:12
before 4.16.4-1
4.16.4-1
node-express
Debian:13
before 4.16.4-1
4.16.4-1
node-express
Debian:14
before 4.16.4-1
4.16.4-1
node-express
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
4.1.1~dfsg-14.1.1~dfsg-1ubuntu0.16.04.1~esm1
None known
node-express
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
4.1.1~dfsg-14.1.1~dfsg-1ubuntu0.18.04.1~esm1
None known

History

History
RecordedChangedSources
affected
affected, aliasesOSV
affected, aliases, factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-6393 is a medium vulnerability (CVSS 6.1) in Openjsf Express, published August 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.14%, the 66th percentile. Fixed in express 3.11.0.

References

MoveEnter Open