CVE-2014-7832
Moodle allows attackers to bypass the mod/lti:view capability requirement
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.
Exploit likelihood
What each source reports
NVD Score used
4.0
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.
- Record
CVE-2014-7832- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.
- Record
CVE-2014-7832- Updated
- 2026-11-02
EUVDEUVD-2022-4602 No score
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.
- Record
EUVD-2022-4602- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mphj-h2fc-62x3 No score
Moodle allows attackers to bypass the mod/lti:view capability requirement
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.
- Record
GHSA-mphj-h2fc-62x3- Updated
- 2026-11-02
OSVGHSA-mphj-h2fc-62x3 No score
Moodle allows attackers to bypass the mod/lti:view capability requirement
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by viewing an activity instance.
- Record
GHSA-mphj-h2fc-62x3- Updated
- 2026-11-02
OSVMGASA-2014-0483 No score
Updated moodle package fixes security vulnerabilities
In Moodle before 2.6.5, without forcing encoding, it was possible that UTF7 characters could be used to force cross-site scripts to AJAX scripts (although this is unlikely on modern browsers and on most Moodle pages) (MSA-14-0035).
In Moodle before 2.6.5, an XSS issue through $searchcourse in mod/feedback/mapcourse.php, due to the last search string in the Feedback module not being escaped in the search input field (CVE-2014-7830).
In Moodle before 2.6.5, the word list for temporary password generation was short, therefore the pool of possible passwords was not big enough (CVE-2014-7845).
In Moodle before 2.6.5, capability checks in the LTI module only checked access to the course and not to the activity (CVE-2014-7832).
In Moodle before 2.6.5, group-level entries in Database activity module became visible to users in other groups after being edited by a teacher (CVE-2014-7833).
In Moodle before 2.6.5, unprivileged users could access the list of available tags in the system (CVE-2014-7846).
In Moodle before 2.6.5, the script used to geo-map IP addresses was available to unauthenticated users increasing server load when used by other parties (CVE-2014-7847).
In Moodle before 2.6.5, when using the web service function for Forum discussions, group permissions were not checked (CVE-2014-7834).
In Moodle before 2.6.5, by directly accessing an internal file, an unauthenticated user can be shown an error message containing the file system path of the Moodle install (CVE-2014-7848).
In Moodle before 2.6.5, if web service with file upload function was available, user could upload XSS file to his profile picture area (CVE-2014-7835).
In Moodle before 2.6.5, two files in the LTI module lacked a session key check, potentially allowing cross-site request forgery (CVE-2014-7836).
In Moodle before 2.6.5, by tweaking URLs, users who were able to delete pages in at least one Wiki activity in the course were able to delete pages in other Wiki pages in the same course (CVE-2014-7837).
In Moodle before 2.6.5, set tracking script in the Forum module lacked a session key check, potentially allowing cross-site request forgery (CVE-2014-7838).
In Moodle before 2.6.5, session key check was missing on return page in module LTI allowing attacker to include arbitrary message in URL query string (MSA-14-0049).
- Record
MGASA-2014-0483- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.5.9 | 2.5.9 |
moodle/moodlePackagist |
2.6.0 up to 2.6.6 | 2.6.6 |
moodle/moodlePackagist |
2.7.0 up to 2.7.3 | 2.7.3 |
moodle/moodlePackagist |
before 2.5.9, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 27 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8 |
2.5.9 |
moodle/moodlePackagist |
2.6.0 up to 2.6.6, plus listed versions v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5 |
2.6.6 |
moodle/moodlePackagist |
2.7.0 up to 2.7.3, plus listed versions v2.7.0v2.7.1v2.7.2 |
2.7.3 |
moodleMageia:3 From an advisory covering 12 CVEs |
before 2.6.6-1.mga3 | 2.6.6-1.mga3 |
moodleMageia:4 From an advisory covering 12 CVEs |
before 2.6.6-1.mga4 | 2.6.6-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-7832 is a medium vulnerability (CVSS 4.0) in Moodle, published November 22, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.71%, the 77th percentile. Fixed in moodle/moodle 2.5.9.
References
securitytracker.com/id/1031215
openwall.com/lists/oss-security/2014/11/17/11
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47921
moodle.org/mod/forum/discuss.php?d=275154
nvd.nist.gov/vuln/detail/CVE-2014-7832
github.com/moodle/moodle/commit/263f78b8b804fe7dbcd6ffadcadad2c94a0093f7
Show 23 moreShow less
github.com/moodle/moodle/commit/8e34d8e85b971a01459797799c0696cfeaae9cc0
github.com/moodle/moodle/commit/c844af2569e972195db8bca683c1fdf2ddbc3a59
github.com/moodle/moodle/commit/fe8430e0dc2a50ea8e03d709e95d1226631d0d52
web.archive.org/web/20150914064838/http://www.securitytracker.com/id/1031215
github.com/advisories/GHSA-mphj-h2fc-62x3
github.com/moodle/moodle
advisories.mageia.org/MGASA-2014-0483.html
bugs.mageia.org/show_bug.cgi?id=14538
moodle.org/mod/forum/discuss.php?d=275146
moodle.org/mod/forum/discuss.php?d=275147
moodle.org/mod/forum/discuss.php?d=275152
moodle.org/mod/forum/discuss.php?d=275155
moodle.org/mod/forum/discuss.php?d=275157
moodle.org/mod/forum/discuss.php?d=275158
moodle.org/mod/forum/discuss.php?d=275159
moodle.org/mod/forum/discuss.php?d=275160
moodle.org/mod/forum/discuss.php?d=275161
moodle.org/mod/forum/discuss.php?d=275162
moodle.org/mod/forum/discuss.php?d=275163
moodle.org/mod/forum/discuss.php?d=275164
moodle.org/mod/forum/discuss.php?d=275165
docs.moodle.org/dev/Moodle_2.6.6_release_notes
moodle.org/mod/forum/discuss.php?d=274730