Every CVE Search/ Get API key

CVE-2014-8882

Regular Expression Denial of Service in validator

7.5 HighFix available

Versions of validator prior to 3.22.1 are affected by a regular expression denial of service vulnerability in the isURL method.

Recommendation

Update to version 3.22.1 or later.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

What each source reports

GitHub Advisories Score usedGHSA-f5w6-r7rg-mcgq 7.5

Regular Expression Denial of Service in validator

Versions of validator prior to 3.22.1 are affected by a regular expression denial of service vulnerability in the isURL method.

Recommendation

Update to version 3.22.1 or later.

Record
GHSA-f5w6-r7rg-mcgq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSVGHSA-f5w6-r7rg-mcgq 7.5

Regular Expression Denial of Service in validator

Versions of validator prior to 3.22.1 are affected by a regular expression denial of service vulnerability in the isURL method.

Recommendation

Update to version 3.22.1 or later.

Record
GHSA-f5w6-r7rg-mcgq
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
validator
npm
before 3.22.1
3.22.1

History

History
RecordedChangedSources
first indexedGitHub Advisories, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8882 is a high vulnerability (CVSS 7.5) in validator, published August 31, 2020. No source lists public exploit code. Fixed in validator 3.22.1.

References

MoveEnter Open