Every CVE Search/ Get API key

CVE-2014-9016

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass)...

5.0 MediumPublic exploitFix available

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.

Exploit likelihood

79.1%Down 9.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.

Record
CVE-2014-9016
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.

Record
CVE-2014-9016
Updated
2026-11-02
EUVDEUVD-2014-8844 No score

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.

Record
EUVD-2014-8844
Updated
2026-11-03
GitHub AdvisoriesGHSA-cfc7-w9hw-779w No score

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass)...

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.

Record
GHSA-cfc7-w9hw-779w
Updated
2026-11-02
OSVMGASA-2014-0492 No score

Updated drupal packages fix security vulnerabilities

Updated drupal packages fix security vulnerability:

Aaron Averill discovered that a specially crafted request can give a user access to another user's session, allowing an attacker to hijack a random session (CVE-2014-9015).

Michael Cullum, Javier Nieto and Andres Rojas Guerrero discovered that the password hashing API allows an attacker to send specially crafted requests resulting in CPU and memory exhaustion. This may lead to the site becoming unavailable or unresponsive (denial of service) (CVE-2014-9016). anonymous users (CVE-2014-9016).

Record
MGASA-2014-0492
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9016 No score

The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x-2.1 for Drupal allows remote attackers to cause a denial of service (CPU and memory consumption) via a crafted request.

Record
UBUNTU-CVE-2014-9016
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal7
Debian:7
before 7.14-2+deb7u8, plus listed versions
7.14-27.14-2+deb7u17.14-2+deb7u1~bpo60+17.14-2+deb7u27.14-2+deb7u2~bpo60+1
Show 8 moreShow less
7.14-2+deb7u37.14-2+deb7u47.14-2+deb7u4~bpo60+17.14-2+deb7u57.14-2+deb7u67.14-2+deb7u6~bpo60+17.14-2+deb7u77.14-2+deb7u7~bpo60+1
7.14-2+deb7u8
drupal
Mageia:3
before 7.34-1.mga3
7.34-1.mga3
drupal
Mageia:4
before 7.34-1.mga4
7.34-1.mga4
drupal7
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
7.23-17.24-17.24-27.26-17.26-1ubuntu0.17.26-1ubuntu0.1+esm17.26-1ubuntu0.1+esm27.26-1ubuntu0.1+esm3
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBDrupal < 7.34 - Denial of Service2014-12-01
MetasploitWordPress Long Password DoS2014-11-20
PoC in GitHubPrimus27/WordPress-Long-Password-Denial-of-Service2020-02-08
PoC in GitHubc0r3dump3d/wp_drupal_timing_attack2014-12-01

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9016 is a medium vulnerability (CVSS 5.0) in Drupal, published November 20, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 79.1%, the 99th percentile. Fixed in drupal7 7.14-2+deb7u8.

References

Show 13 moreShow less
MoveEnter Open