Every CVE Search/ Get API key

CVE-2014-9060

Moodle allows attackers to trigger the generation of arbitrary messages

5.0 MediumFix available

The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

Exploit likelihood

2.12%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

Record
CVE-2014-9060
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

Record
CVE-2014-9060
Updated
2026-11-02
EUVDEUVD-2022-3532 No score

The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

Record
EUVD-2022-3532
Updated
2026-11-03
GitHub AdvisoriesGHSA-c87j-9rrq-h3j8 No score

Moodle allows attackers to trigger the generation of arbitrary messages

The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

Record
GHSA-c87j-9rrq-h3j8
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-c87j-9rrq-h3j8 No score

Moodle allows attackers to trigger the generation of arbitrary messages

The LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not properly restrict the parameters used in a return URL, which allows remote attackers to trigger the generation of arbitrary messages via a modified URL, related to mod/lti/locallib.php and mod/lti/return.php.

Record
GHSA-c87j-9rrq-h3j8
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.5.9
2.5.9
moodle/moodle
Packagist
2.6.0 up to 2.6.6
2.6.6
moodle/moodle
Packagist
2.7.0 up to 2.7.3
2.7.3
moodle/moodle
Packagist
before 2.5.9, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 27 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8
2.5.9
moodle/moodle
Packagist
2.6.0 up to 2.6.6, plus listed versions
v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5
2.6.6
moodle/moodle
Packagist
2.7.0 up to 2.7.3, plus listed versions
v2.7.0v2.7.1v2.7.2
2.7.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9060 is a medium vulnerability (CVSS 5.0) in Moodle, published November 24, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in moodle/moodle 2.5.9.

References

Show 6 moreShow less
MoveEnter Open