Every CVE Search/ Get API key

CVE-2014-9258

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote...

6.5 MediumPublic exploitFix available

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.

Exploit likelihood

3.40%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.

Record
CVE-2014-9258
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.

Record
CVE-2014-9258
Updated
2026-11-02
EUVDEUVD-2014-9083 No score

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.

Record
EUVD-2014-9083
Updated
2026-11-03
GitHub AdvisoriesGHSA-rv52-jqj3-929g No score

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote...

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.

Record
GHSA-rv52-jqj3-929g
Weakness
CWE-89
Updated
2026-11-02
OSVMGASA-2015-0017 No score

Updated glpi package fixes security vulnerabilities

Updated glpi package fixes security vulnerabilities:

Due to a bug in GLPI before 0.84.7, a user without access to cost information can in fact see the information when selecting cost as a search criteria (CVE-2014-5032).

An issue in GLPI before 0.84.8 may allow arbitrary local files to be included by PHP through an autoload function (CVE-2014-8360).

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter (CVE-2014-9258).

Record
MGASA-2015-0017
Updated
2026-11-02
OSVUBUNTU-CVE-2014-9258 No score

SQL injection vulnerability in ajax/getDropdownValue.php in GLPI before 0.85.1 allows remote authenticated users to execute arbitrary SQL commands via the condition parameter.

Record
UBUNTU-CVE-2014-9258
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glpi
Mageia:4
before 0.84.3-1.2.mga4
0.84.3-1.2.mga4
glpi
Ubuntu:16.04:LTS
All versions, plus listed versions
0.84.8+dfsg.1-10.84.8+dfsg.1-1ubuntu1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBGLPI 0.85 - Blind SQL Injection2014-12-15

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9258 is a medium vulnerability (CVSS 6.5) in Glpi-project Glpi, published December 19, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.40%, the 88th percentile. Fixed in glpi 0.84.3-1.2.mga4.

References

Show 12 moreShow less
MoveEnter Open