Every CVE Search/ Get API key

CVE-2014-9475

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1...

3.5 LowFix available

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Exploit likelihood

1.45%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Record
CVE-2014-9475
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Record
CVE-2014-9475
Updated
2026-11-02
EUVDEUVD-2014-9294 No score

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Record
EUVD-2014-9294
Updated
2026-11-03
GitHub AdvisoriesGHSA-68mq-r5mx-h5r5 No score

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1...

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Record
GHSA-68mq-r5mx-h5r5
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Record
CVE-2014-9475
Updated
2026-11-02
OSVDEBIAN-CVE-2014-9475 No score

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.19.23, 1.2x before 1.22.15, 1.23.x before 1.23.8, and 1.24.x before 1.24.1 allows remote authenticated users to inject arbitrary web script or HTML via a wikitext message.

Record
DEBIAN-CVE-2014-9475
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.19.20+dfsg-2.2
1:1.19.20+dfsg-2.2
mediawiki
Debian:13
before 1:1.19.20+dfsg-2.2
1:1.19.20+dfsg-2.2
mediawiki
Debian:14
before 1:1.19.20+dfsg-2.2
1:1.19.20+dfsg-2.2
mediawiki
Debian:7
before 1:1.19.20+dfsg-0+deb7u3, plus listed versions
1:1.19.10+dfsg-11:1.19.11+dfsg-0+deb7u11:1.19.11+dfsg-11:1.19.12+dfsg-11:1.19.13+dfsg-1
Show 26 moreShow less
1:1.19.14+dfsg-0+deb7u11:1.19.14+dfsg-0+deb7u21:1.19.14+dfsg-11:1.19.15+dfsg-0+deb7u11:1.19.15+dfsg-11:1.19.15+dfsg-21:1.19.16+dfsg-0+deb7u11:1.19.16+dfsg-11:1.19.17+dfsg-11:1.19.18+dfsg-0+deb7u11:1.19.18+dfsg-0.11:1.19.19+dfsg-0+deb7u11:1.19.19+dfsg-11:1.19.20+dfsg-0+deb7u11:1.19.20+dfsg-0+deb7u21:1.19.5-11:1.19.5-1+deb7u11:1.19.6-11:1.19.7+dfsg-11:1.19.7+dfsg-1.11:1.19.8+dfsg-11:1.19.8+dfsg-21:1.19.8+dfsg-2.11:1.19.8+dfsg-2.21:1.19.9+dfsg-11:1.19.9+dfsg-2
1:1.19.20+dfsg-0+deb7u3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-9475 is a low vulnerability (CVSS 3.5) in Mediawiki, published December 23, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in mediawiki 1:1.19.20+dfsg-2.2.

References

MoveEnter Open