CVE-2014-9489
gollum and gollum-lib allow remote authenticated users to execute arbitrary code
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string "master" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string "master" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
- Record
CVE-2014-9489- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-284
- Updated
- 2026-11-02
CVE List No score
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string "master" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
- Record
CVE-2014-9489- Updated
- 2026-11-02
EUVDEUVD-2017-0352 No score
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string "master" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
- Record
EUVD-2017-0352- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q97v-764g-r2rp
8.8
gollum and gollum-lib allow remote authenticated users to execute arbitrary code
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
- Record
GHSA-q97v-764g-r2rp- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGHSA-q97v-764g-r2rp
8.8
gollum and gollum-lib allow remote authenticated users to execute arbitrary code
The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.
- Record
GHSA-q97v-764g-r2rp- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gollumRubyGems |
before 3.1.1 | 3.1.1 |
gollum-libRubyGems |
before 4.0.1 | 4.0.1 |
gollumRubyGems |
before 3.1.1, plus listed versions 1.0.01.0.11.1.01.1.11.2.0 Show 45 moreShow less1.2.11.3.01.3.11.4.21.4.32.0.02.1.02.1.102.1.22.1.32.1.42.1.62.1.72.1.82.1.92.2.02.2.12.2.22.2.32.2.42.2.52.2.62.2.72.2.82.2.92.3.02.3.12.3.102.3.112.3.122.3.22.3.32.3.42.3.52.3.62.3.72.3.82.3.92.4.02.4.12.4.102.4.112.4.122.4.132.4.14 |
3.1.1 |
gollum-libRubyGems |
before 4.0.1, plus listed versions 0.0.11.0.01.0.11.0.21.0.3 Show 9 moreShow less1.0.41.0.51.0.61.0.71.0.81.0.92.0.03.0.04.0.0 |
4.0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9489 is a high vulnerability (CVSS 8.8) in Gollum Project Gollum, published October 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.94%, the 87th percentile. Fixed in gollum 3.1.1.
References
openwall.com/lists/oss-security/2015/01/03/19
securityfocus.com/bid/71499
github.com/gollum/grit_adapter/commit/4520d973c81fecfebbeacd2ef2f1849d763951c7
github.com/gollum/gollum/issues/913
nvd.nist.gov/vuln/detail/CVE-2014-9489
web.archive.org/web/20200229041306/http://www.securityfocus.com/bid/71499
github.com/advisories/GHSA-q97v-764g-r2rp
github.com/gollum/gollum
Left out here: 16 versions. The JSON record has them.