CVE-2014-9682
dns-sync command injection vulnerability
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
Exploit likelihood
What each source reports
NVD Score used
10.0
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
- Record
CVE-2014-9682- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List No score
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
- Record
CVE-2014-9682- Updated
- 2026-11-02
EUVDEUVD-2017-0287 No score
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
- Record
EUVD-2017-0287- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q5pq-pgrv-fh89 No score
dns-sync command injection vulnerability
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
- Record
GHSA-q5pq-pgrv-fh89- Weakness
- CWE-77
- Updated
- 2026-11-02
OSVGHSA-q5pq-pgrv-fh89 No score
dns-sync command injection vulnerability
The dns-sync module before 0.1.1 for node.js allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the first argument to the resolve API function.
- Record
GHSA-q5pq-pgrv-fh89- Weakness
- CWE-77
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dns-syncnpm |
before 0.1.1 | 0.1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9682 is a high vulnerability (CVSS 10.0) in Dns-sync Project Dns-sync, published February 28, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.84%, the 86th percentile. Fixed in dns-sync 0.1.1.