CVE-2014-9766
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6...
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
CVE-2014-9766- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-189
- Updated
- 2026-11-02
CVE List No score
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
CVE-2014-9766- Updated
- 2026-11-02
EUVDEUVD-2014-9572 No score
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
EUVD-2014-9572- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wrhh-9jw8-888j
9.8
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6...
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
GHSA-wrhh-9jw8-888j- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
CVE-2014-9766- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-9766
9.8
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
DEBIAN-CVE-2014-9766- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-9766
9.8
Integer overflow in the create_bits function in pixman-bits-image.c in Pixman before 0.32.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via large height and stride values.
- Record
UBUNTU-CVE-2014-9766- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-2918-1 No score
pixman vulnerability
Vincent LE GARREC discovered an integer underflow in pixman. If a user were tricked into opening a specially crafted file, a remote attacker could cause pixman to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-2918-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pixmanDebian:12 |
before 0.32.6-1 | 0.32.6-1 |
pixmanDebian:13 |
before 0.32.6-1 | 0.32.6-1 |
pixmanDebian:14 |
before 0.32.6-1 | 0.32.6-1 |
pixmanDebian:6.0 |
before 0.16.4-1+deb6u2, plus listed versions 0.16.4-1 |
0.16.4-1+deb6u2 |
pixmanDebian:7 |
before 0.26.0-4+deb7u2, plus listed versions 0.26.0-40.26.0-4+deb7u1 |
0.26.0-4+deb7u2 |
pixmanUbuntu:14.04:LTS |
before 0.30.2-2ubuntu1.1, plus listed versions 0.30.2-10.30.2-20.30.2-2ubuntu1 |
0.30.2-2ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-9766 is a critical vulnerability (CVSS 9.8) in Pixman, published December 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.62%, the 92nd percentile. Fixed in pixman 0.32.6-1.
References
bugs.freedesktop.org/show_bug.cgi?id=69014
lists.freedesktop.org/archives/pixman/2014-April/003244.html
openwall.com/lists/oss-security/2016/02/24/13
cgit.freedesktop.org/pixman/commit?id=857e40f3d2bc2cfb714913e0cd7e6184cf69aca3
bugzilla.redhat.com/show_bug.cgi?id=972647
oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
Show 10 moreShow less
openwall.com/lists/oss-security/2016/02/24/15
lists.x.org/archives/xorg-announce/2014-July/002452.html
ubuntu.com/usn/USN-2918-1
debian.org/security/2016/dsa-3525
nvd.nist.gov/vuln/detail/CVE-2014-9766
github.com/advisories/GHSA-wrhh-9jw8-888j
security-tracker.debian.org/tracker/CVE-2014-9766
ubuntu.com/security/CVE-2014-9766
ubuntu.com/security/notices/USN-2918-1
cve.org/CVERecord?id=CVE-2014-9766