CVE-2014-9906
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of...
CVE-2014-9906 is a critical vulnerability (CVSS 9.8) in Dbd-mysql Project Dbd-mysql, published July 29, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.08%, the 93rd percentile. Fixed in libdbd-mysql-perl 4.033-1.
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
CVE-2014-9906- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
CVE-2014-9906- Updated
- 2026-11-02
EUVDEUVD-2014-9711 No score
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
EUVD-2014-9711- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-676f-4267-c5c3
9.8
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of...
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
GHSA-676f-4267-c5c3- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
9.8
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
CVE-2014-9906- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-9906
9.8
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
DEBIAN-CVE-2014-9906- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-9906
9.8
Use-after-free vulnerability in DBD::mysql before 4.029 allows attackers to cause a denial of service (program crash) or possibly execute arbitrary code via vectors related to a lost server connection.
- Record
UBUNTU-CVE-2014-9906- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2016-0300 No score
Updated perl-DBD-mysql packages fix security vulnerability
Two use-after-free vulnerabilities were discovered in DBD::mysql. A remote attacker can take advantage of these flaws to cause a denial-of-service against an application using DBD::mysql (application crash), or potentially to execute arbitrary code with the privileges of the user running the application(CVE-2014-9906, CVE-2015-8949).
- Record
MGASA-2016-0300- Updated
- 2026-11-02
OSVUSN-3103-1 No score
libdbd-mysql-perl vulnerabilities
It was discovered that DBD::mysql incorrectly handled certain memory operations. A remote attacker could use this issue to cause DBD::mysql to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2014-9906)
Hanno Böck discovered that DBD::mysql incorrectly handled certain memory operations. A remote attacker could use this issue to cause DBD::mysql to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2015-8949)
Pali Rohár discovered that DBD::mysql incorrectly handled certain user supplied data. A remote attacker could use this issue to cause DBD::mysql to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-1246)
- Record
USN-3103-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libdbd-mysql-perlDebian:12 |
before 4.033-1 | 4.033-1 |
libdbd-mysql-perlDebian:13 |
before 4.033-1 | 4.033-1 |
libdbd-mysql-perlDebian:14 |
before 4.033-1 | 4.033-1 |
libdbd-mysql-perlDebian:7 |
before 4.021-1+deb7u1, plus listed versions 4.021-1 |
4.021-1+deb7u1 |
libdbd-mysql-perlDebian:8 |
before 4.028-2+deb8u1, plus listed versions 4.028-2 |
4.028-2+deb8u1 |
perl-DBD-mysqlMageia:5 |
before 4.28.0-3.1.mga5 | 4.28.0-3.1.mga5 |
libdbd-mysql-perlUbuntu:14.04:LTS |
before 4.025-1ubuntu0.1, plus listed versions 4.023-14.024-14.025-1 |
4.025-1ubuntu0.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
rt.cpan.org/Public/Bug/Display.html?id=97625
openwall.com/lists/oss-security/2016/07/27/5
github.com/perl5-dbi/DBD-mysql/commit/a56ae87a4c1c1fead7d09c3653905841ccccf1cc
openwall.com/lists/oss-security/2016/07/27/6
debian.org/security/2016/dsa-3635
cpansearch.perl.org/src/CAPTTOFU/DBD-mysql-4.029/ChangeLog
Show 12 moreShow less
securityfocus.com/bid/92149
nvd.nist.gov/vuln/detail/CVE-2014-9906
github.com/advisories/GHSA-676f-4267-c5c3
security-tracker.debian.org/tracker/CVE-2014-9906
advisories.mageia.org/MGASA-2016-0300.html
bugs.mageia.org/show_bug.cgi?id=19050
ubuntu.com/security/CVE-2014-9906
github.com/perl5-dbi/DBD-mysql/pull/27
ubuntu.com/security/notices/USN-3103-1
cve.org/CVERecord?id=CVE-2014-9906
ubuntu.com/security/CVE-2015-8949
ubuntu.com/security/CVE-2016-1246