Every CVE Search/ Get API key

CVE-2015-0214

Moodle allows attackers to bypass a messaging-disabled setting

4.0 MediumFix available

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Exploit likelihood

1.70%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Record
CVE-2015-0214
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Record
CVE-2015-0214
Updated
2026-11-02
EUVDEUVD-2022-2401 No score

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Record
EUVD-2022-2401
Updated
2026-11-03
GitHub AdvisoriesGHSA-4jm2-c9jr-6prf No score

Moodle allows attackers to bypass a messaging-disabled setting

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Record
GHSA-4jm2-c9jr-6prf
Updated
2026-11-02
OSVGHSA-4jm2-c9jr-6prf No score

Moodle allows attackers to bypass a messaging-disabled setting

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Record
GHSA-4jm2-c9jr-6prf
Updated
2026-11-02
OSVMGASA-2015-0032 No score

Updated moodle package fixes security vulnerabilities

Updated moodle package fixes security vulnerabilities:

In Moodle before 2.6.7, absence of a capability check in AJAX backend script in the LTI module could allow any enrolled user to search the list of registered tools (CVE-2015-0211).

In Moodle before 2.6.7, the course summary on course request pending approval page was displayed to the manager unescaped and could be used for XSS attack (CVE-2015-0212).

In Moodle before 2.6.7, two files in the Glossary module lacked a session key check potentially allowing cross-site request forgery (CVE-2015-0213).

In Moodle before 2.6.7, through web-services it was possible to access messaging-related functions such as people search even if messaging is disabled on the site (CVE-2015-0214).

In Moodle before 2.6.7, through web-services it was possible to get information about calendar events which user did not have enough permissions to see (CVE-2015-0215).

In Moodle before 2.6.7, non-optimal regular expression in the multimedia filter could be exploited to create extra server load or make particular page unavailable, resulting in a denial of service (CVE-2015-0217).

In Moodle before 2.6.7, it was possible to forge a request to logout users even when not authenticated through Shibboleth (CVE-2015-0218).

Record
MGASA-2015-0032
Updated
2026-11-02
OSVUBUNTU-CVE-2015-0214 No score

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Record
UBUNTU-CVE-2015-0214
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.6.7
2.6.7
moodle/moodle
Packagist
2.7.0 up to 2.7.4
2.7.4
moodle/moodle
Packagist
2.8.0 up to 2.8.2
2.8.2
moodle/moodle
Packagist
before 2.6.7, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 37 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6
2.6.7
moodle/moodle
Packagist
2.7.0 up to 2.7.4, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3
2.7.4
moodle/moodle
Packagist
2.8.0 up to 2.8.2, plus listed versions
v2.8.0v2.8.1
2.8.2
moodle
Mageia:4
From an advisory covering 7 CVEs
before 2.6.7-1.mga4
2.6.7-1.mga4

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-0214 is a medium vulnerability (CVSS 4.0) in Moodle, published January 20, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.70%, the 77th percentile. Fixed in moodle/moodle 2.6.7.

References

Show 16 moreShow less
MoveEnter Open