CVE-2015-0218
Moodle cross-site request forgery (CSRF) vulnerability
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
Exploit likelihood
What each source reports
NVD Score used
6.8
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
- Record
CVE-2015-0218- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
- Record
CVE-2015-0218- Updated
- 2026-11-02
EUVDEUVD-2022-2612 No score
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
- Record
EUVD-2022-2612- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5jph-mvfm-r27p No score
Moodle cross-site request forgery (CSRF) vulnerability
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
- Record
GHSA-5jph-mvfm-r27p- Weakness
- CWE-352
- Updated
- 2026-11-02
OSVGHSA-5jph-mvfm-r27p No score
Moodle cross-site request forgery (CSRF) vulnerability
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
- Record
GHSA-5jph-mvfm-r27p- Weakness
- CWE-352
- Updated
- 2026-11-02
OSVMGASA-2015-0032 No score
Updated moodle package fixes security vulnerabilities
Updated moodle package fixes security vulnerabilities:
In Moodle before 2.6.7, absence of a capability check in AJAX backend script in the LTI module could allow any enrolled user to search the list of registered tools (CVE-2015-0211).
In Moodle before 2.6.7, the course summary on course request pending approval page was displayed to the manager unescaped and could be used for XSS attack (CVE-2015-0212).
In Moodle before 2.6.7, two files in the Glossary module lacked a session key check potentially allowing cross-site request forgery (CVE-2015-0213).
In Moodle before 2.6.7, through web-services it was possible to access messaging-related functions such as people search even if messaging is disabled on the site (CVE-2015-0214).
In Moodle before 2.6.7, through web-services it was possible to get information about calendar events which user did not have enough permissions to see (CVE-2015-0215).
In Moodle before 2.6.7, non-optimal regular expression in the multimedia filter could be exploited to create extra server load or make particular page unavailable, resulting in a denial of service (CVE-2015-0217).
In Moodle before 2.6.7, it was possible to forge a request to logout users even when not authenticated through Shibboleth (CVE-2015-0218).
- Record
MGASA-2015-0032- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-0218 No score
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
- Record
UBUNTU-CVE-2015-0218- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.6.7 | 2.6.7 |
moodle/moodlePackagist |
2.7.0 up to 2.7.4 | 2.7.4 |
moodle/moodlePackagist |
2.8.0 up to 2.8.2 | 2.8.2 |
moodle/moodlePackagist |
before 2.6.7, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 37 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6 |
2.6.7 |
moodle/moodlePackagist |
2.7.0 up to 2.7.4, plus listed versions v2.7.0v2.7.1v2.7.2v2.7.3 |
2.7.4 |
moodle/moodlePackagist |
2.8.0 up to 2.8.2, plus listed versions v2.8.0v2.8.1 |
2.8.2 |
moodleMageia:4 From an advisory covering 7 CVEs |
before 2.6.7-1.mga4 | 2.6.7-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-0218 is a medium vulnerability (CVSS 6.8) in Moodle, published January 20, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in moodle/moodle 2.6.7.
References
moodle.org/mod/forum/discuss.php?d=278618
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47964
openwall.com/lists/oss-security/2015/01/19/1
nvd.nist.gov/vuln/detail/CVE-2015-0218
github.com/moodle/moodle/commit/371d58d70d4ef866f35e33ea6898007112bfe654
github.com/moodle/moodle/commit/693918c30e6b7c95dddd9c5973f98d98342a59d9
Show 16 moreShow less
github.com/moodle/moodle/commit/b82b4c562b705ea8f11893d9126889bb696b9612
github.com/moodle/moodle/commit/fb60e23a67931eeba8fc9aacf3cc838e462f21f2
github.com/advisories/GHSA-5jph-mvfm-r27p
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0032.html
bugs.mageia.org/show_bug.cgi?id=15084
moodle.org/mod/forum/discuss.php?d=278611
moodle.org/mod/forum/discuss.php?d=278612
moodle.org/mod/forum/discuss.php?d=278613
moodle.org/mod/forum/discuss.php?d=278614
moodle.org/mod/forum/discuss.php?d=278615
moodle.org/mod/forum/discuss.php?d=278617
docs.moodle.org/dev/Moodle_2.6.7_release_notes
moodle.org/mod/forum/discuss.php?d=278176
ubuntu.com/security/CVE-2015-0218
cve.org/CVERecord?id=CVE-2015-0218