Every CVE Search/ Get API key

CVE-2015-0242

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19,...

8.8 High

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.14%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

Record
CVE-2015-0242
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

Record
CVE-2015-0242
Updated
2026-11-02
EUVDEUVD-2015-0264 No score

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

Record
EUVD-2015-0264
Updated
2026-11-03
GitHub AdvisoriesGHSA-484w-vg65-78pg No score

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19,...

Stack-based buffer overflow in the *printf function implementations in PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1, when running on a Windows system, allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via a floating point number with a large precision, as demonstrated by using the to_char function.

Record
GHSA-484w-vg65-78pg
Updated
2026-11-02
OSVMGASA-2015-0069 No score

Updated postgresql packages fix security vulnerabilities

Updated postgresql packages fix security vulnerabilities:

A user with limited clearance on a table might have access to information in columns without SELECT rights on through server error messages (CVE-2014-8161).

The function to_char() might read/write past the end of a buffer. This might crash the server when a formatting template is processed (CVE-2015-0241).

The pgcrypto module is vulnerable to stack buffer overrun that might crash the server (CVE-2015-0243).

Emil Lenngren reported that an attacker can inject SQL commands when the synchronization between client and server is lost (CVE-2015-0244).

This update provides PostgreSQL versions 9.3.6, 9.2.10, 9.1.15, and 9.0.19 that fix these issues, as well as several others.

Record
MGASA-2015-0069
Updated
2026-11-02
OSVopenSUSE-SU-2024:10256-1 No score

postgresql93-9.3.15-1.1 on GA media

These are all security issues fixed in the postgresql93-9.3.15-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10256-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql9.0
Mageia:4
From an advisory covering 5 CVEs
before 9.0.19-1.mga4
9.0.19-1.mga4
postgresql9.1
Mageia:4
From an advisory covering 5 CVEs
before 9.1.15-1.mga4
9.1.15-1.mga4
postgresql9.2
Mageia:4
From an advisory covering 5 CVEs
before 9.2.10-1.mga4
9.2.10-1.mga4
postgresql9.3
Mageia:4
From an advisory covering 5 CVEs
before 9.3.6-1.mga4
9.3.6-1.mga4
postgresql93
openSUSE:Tumbleweed
From an advisory covering 40 CVEs
before 9.3.15-1.1
9.3.15-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-0242 is a high vulnerability (CVSS 8.8) in Postgresql, published February 17, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.14%, the 92nd percentile. No source names a fixed version.

References

Show 45 moreShow less
MoveEnter Open