CVE-2015-0265
Apache Ranger Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
- Record
CVE-2015-0265- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
- Record
CVE-2015-0265- Updated
- 2026-11-02
EUVDEUVD-2015-0281 No score
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
- Record
EUVD-2015-0281- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-83m2-9g78-rrj4
6.1
Apache Ranger Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
- Record
GHSA-83m2-9g78-rrj4- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-83m2-9g78-rrj4
6.1
Apache Ranger Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
- Record
GHSA-83m2-9g78-rrj4- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.ranger:rangerMaven |
before 0.5.0 | 0.5.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-0265 is a medium vulnerability (CVSS 6.1) in Apache Ranger, published April 11, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.85%, the 92nd percentile. Fixed in org.apache.ranger:ranger 0.5.0.
References
mail-archives.apache.org/mod_mbox/ranger-dev/201508.mbox/%3CD1E7EC30.9D53F%25vel%40apache.org%3E
slideshare.net/wojdwo/big-problems-with-big-data-hadoop-interfaces-security
cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger
securityfocus.com/bid/76208
nvd.nist.gov/vuln/detail/CVE-2015-0265
mail-archives.apache.org/mod_mbox/ranger-dev/201508.mbox/%3CD1E7EC30.9D53F%[email protected]%3E
web.archive.org/web/20200228073946/http://www.securityfocus.com/bid/76208
github.com/advisories/GHSA-83m2-9g78-rrj4
github.com/apache/ranger