CVE-2015-0270
Zend Framework Allows SQL Injection
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
- Record
CVE-2015-0270- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
- Record
CVE-2015-0270- Updated
- 2026-11-02
EUVDEUVD-2022-5285 No score
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
- Record
EUVD-2022-5285- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v59p-p692-v382
9.8
Zend Framework Allows SQL Injection
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
- Record
GHSA-v59p-p692-v382- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-v59p-p692-v382
9.8
Zend Framework Allows SQL Injection
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
- Record
GHSA-v59p-p692-v382- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zendframework/zendframeworkPackagist |
before 2.2.10 | 2.2.10 |
zendframework/zendframeworkPackagist |
2.3.0 up to 2.3.5 | 2.3.5 |
zendframework/zend-dbPackagist |
before 2.2.10 | 2.2.10 |
zendframework/zend-dbPackagist |
2.3.0 up to 2.3.5 | 2.3.5 |
zendframework/zendframeworkPackagist |
before 2.2.10, plus listed versions 2.0.02.0.0beta42.0.0beta52.0.0rc12.0.0rc2 Show 33 moreShow less2.0.0rc32.0.0rc42.0.0rc52.0.0rc62.0.0rc72.0.12.0.22.0.32.0.42.0.52.0.62.0.72.0.82.1.02.1.12.1.22.1.32.1.42.1.52.1.62.2.02.2.0rc12.2.0rc22.2.0rc32.2.12.2.22.2.32.2.42.2.52.2.62.2.72.2.82.2.9 |
2.2.10 |
zendframework/zendframeworkPackagist |
2.3.0 up to 2.3.5, plus listed versions 2.3.12.3.22.3.32.3.4 |
2.3.5 |
zendframework/zend-dbPackagist |
before 2.2.10, plus listed versions 2.0.32.0.42.0.52.0.62.0.7 Show 21 moreShow less2.0.82.1.02.1.12.1.22.1.32.1.42.1.52.1.62.2.02.2.0rc12.2.0rc22.2.0rc32.2.12.2.22.2.32.2.42.2.52.2.62.2.72.2.82.2.9 |
2.2.10 |
zendframework/zend-dbPackagist |
2.3.0 up to 2.3.5, plus listed versions 2.3.12.3.22.3.32.3.4 |
2.3.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-0270 is a critical vulnerability (CVSS 9.8) in Zend Framework, published October 25, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. Fixed in zendframework/zendframework 2.2.10.
References
framework.zend.com/security/advisory/ZF2015-02
nvd.nist.gov/vuln/detail/CVE-2015-0270
github.com/zendframework/zendframework/commit/569f18228f5fc84534af6ff2f367ca1a7143ec65
github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-db/CVE-2015-0270.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework/CVE-2015-0270.yaml
github.com/advisories/GHSA-v59p-p692-v382
github.com/zendframework/zendframework