CVE-2015-0843
yubiserver before 0.6 is to buffer overflows due to misuse of sprintf.
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
- Record
CVE-2015-0843- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2015-0855
9.8
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
- Record
EUVD-2015-0855- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x9xr-v9hc-3r27
9.8
yubiserver before 0.6 is to buffer overflows due to misuse of sprintf.
yubiserver before 0.6 is to buffer overflows due to misuse of sprintf.
- Record
GHSA-x9xr-v9hc-3r27- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
NVD
9.8
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
- Record
CVE-2015-0843- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-0843
9.8
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
- Record
DEBIAN-CVE-2015-0843- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-0843
9.8
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
- Record
UBUNTU-CVE-2015-0843- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
yubiserver before 0.6 is prone to buffer overflows due to misuse of sprintf.
- Record
CVE-2015-0843- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yubiserverDebian:12 |
before 0.6-1 | 0.6-1 |
yubiserverDebian:13 |
before 0.6-1 | 0.6-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-0843 is a critical vulnerability (CVSS 9.8) in Debian Yubiserver, published June 26, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 38th percentile. Fixed in yubiserver 0.6-1.