CVE-2015-1239
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in...
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
CVE-2015-1239- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-415
- Updated
- 2026-11-02
CVE List No score
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
CVE-2015-1239- Updated
- 2026-11-02
EUVDEUVD-2015-1380 No score
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
EUVD-2015-1380- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-935h-fp8w-9vph
6.5
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in...
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
GHSA-935h-fp8w-9vph- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
OSV
6.5
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
CVE-2015-1239- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-1239
6.5
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
DEBIAN-CVE-2015-1239- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-1239
6.5
Double free vulnerability in the j2k_read_ppm_v3 function in OpenJPEG before r2997, as used in PDFium in Google Chrome, allows remote attackers to cause a denial of service (process crash) via a crafted PDF.
- Record
UBUNTU-CVE-2015-1239- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2018:1364-1 No score
Security update for openjpeg2
This update for openjpeg2 fixes the following security issues:
- CVE-2015-1239: A double free vulnerability in the j2k_read_ppm_v3 function allowed remote attackers to cause a denial of service (crash) (bsc#1066713)
- CVE-2017-17479: A stack-based buffer overflow in the pgxtoimage function in jpwl/convert.c could crash the converter. (bsc#1072125)
- CVE-2017-17480: A stack-based buffer overflow in the pgxtovolume function in jp3d/convert.c could crash the converter. (bsc#1072124)
- Record
SUSE-SU-2018:1364-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openjpeg2Debian:12 |
before 2.1.1-1 | 2.1.1-1 |
openjpeg2Debian:13 |
before 2.1.1-1 | 2.1.1-1 |
openjpeg2Debian:14 |
before 2.1.1-1 | 2.1.1-1 |
openjpeg2Debian:8 From an advisory covering 2 CVEs |
before 2.1.0-2+deb8u4, plus listed versions 2.1.0-22.1.0-2+deb8u12.1.0-2+deb8u22.1.0-2+deb8u3 |
2.1.0-2+deb8u4 |
openjpeg2SUSE:Linux Enterprise Desktop 12 SP3 From an advisory covering 3 CVEs |
before 2.1.0-4.9.1 | 2.1.0-4.9.1 |
openjpeg2SUSE:Linux Enterprise Server 12 SP3 From an advisory covering 3 CVEs |
before 2.1.0-4.9.1 | 2.1.0-4.9.1 |
openjpeg2SUSE:Linux Enterprise Server for SAP Applications 12 SP3 From an advisory covering 3 CVEs |
before 2.1.0-4.9.1 | 2.1.0-4.9.1 |
openjpeg2Ubuntu:16.04:LTS |
before 2.1.2-1.1+deb9u2build0.1, plus listed versions 2.1.0-2.12.1.0-2.1ubuntu0.1 |
2.1.2-1.1+deb9u2build0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1239 is a medium vulnerability (CVSS 6.5) in Google Chrome, published October 18, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in openjpeg2 2.1.1-1.
References
lists.debian.org/debian-lts-announce/2018/07/msg00025.html
bugs.chromium.org/p/chromium/issues/detail?id=457493
bugs.chromium.org/p/chromium/issues/detail?id=430891
nvd.nist.gov/vuln/detail/CVE-2015-1239
github.com/advisories/GHSA-935h-fp8w-9vph
security-tracker.debian.org/tracker/CVE-2015-1239
Show 11 moreShow less
suse.com/support/update/announcement/2018/suse-su-20181364-1
bugzilla.suse.com/1066713
bugzilla.suse.com/1072124
bugzilla.suse.com/1072125
suse.com/security/cve/CVE-2015-1239
suse.com/security/cve/CVE-2017-17479
suse.com/security/cve/CVE-2017-17480
ubuntu.com/security/CVE-2015-1239
gist.github.com/bittorrent3389/8fee7cdaa73d1d351ee9
github.com/uclouvain/openjpeg/commit/28c6f547987e8cbe5ccaef622da4cf6667068989
cve.org/CVERecord?id=CVE-2015-1239