Every CVE Search/ Get API key

CVE-2015-1493

Moodle directory traversal vulnerability

6.8 MediumFix available

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Exploit likelihood

2.62%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Record
CVE-2015-1493
CVSS 2.0
6.8 MediumAV:N/AC:L/Au:S/C:C/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Record
CVE-2015-1493
Updated
2026-11-02
EUVDEUVD-2022-3985 No score

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Record
EUVD-2022-3985
Updated
2026-11-03
GitHub AdvisoriesGHSA-gphj-63h8-r9vq No score

Moodle directory traversal vulnerability

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Record
GHSA-gphj-63h8-r9vq
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-gphj-63h8-r9vq No score

Moodle directory traversal vulnerability

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Record
GHSA-gphj-63h8-r9vq
Weakness
CWE-22
Updated
2026-11-02
OSVMGASA-2015-0057 No score

Updated moodle packages fix CVE-2015-1493

Updated moodle package fixes security vulnerability:

In Moodle before 2.6.8, parameter "file" passed to scripts serving JS was not always cleaned from including "../" in the path, allowing to read files located outside of moodle directory. All OS's are affected, but especially vulnerable are Windows servers (CVE-2015-1493).

Record
MGASA-2015-0057
Updated
2026-11-02
OSVUBUNTU-CVE-2015-1493 No score

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Record
UBUNTU-CVE-2015-1493
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.6.8
2.6.8
moodle/moodle
Packagist
2.7.0 up to 2.7.5
2.7.5
moodle/moodle
Packagist
2.8.0 up to 2.8.3
2.8.3
moodle/moodle
Packagist
before 2.6.8, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 38 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7
2.6.8
moodle/moodle
Packagist
2.7.0 up to 2.7.5, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4
2.7.5
moodle/moodle
Packagist
2.8.0 up to 2.8.3, plus listed versions
v2.8.0v2.8.1v2.8.2
2.8.3
moodle
Mageia:4
before 2.6.8-1.mga4
2.6.8-1.mga4

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1493 is a medium vulnerability (CVSS 6.8) in Moodle, published February 9, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.62%, the 85th percentile. Fixed in moodle/moodle 2.6.8.

References

Show 14 moreShow less
MoveEnter Open