Every CVE Search/ Get API key

CVE-2015-1592

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7...

7.5 HighPublic exploitFix available

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7 does not properly use the Perl Storable::thaw function, which allows remote attackers to include and execute arbitrary local Perl files and possibly execute arbitrary code via unspecified vectors.

Exploit likelihood

74.8%Down 17.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7 does not properly use the Perl Storable::thaw function, which allows remote attackers to include and execute arbitrary local Perl files and possibly execute arbitrary code via unspecified vectors.

Record
CVE-2015-1592
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-74
Updated
2026-11-02
CVE List No score

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7 does not properly use the Perl Storable::thaw function, which allows remote attackers to include and execute arbitrary local Perl files and possibly execute arbitrary code via unspecified vectors.

Record
CVE-2015-1592
Updated
2026-11-02
EUVDEUVD-2015-1723 No score

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7 does not properly use the Perl Storable::thaw function, which allows remote attackers to include and execute arbitrary local Perl files and possibly execute arbitrary code via unspecified vectors.

Record
EUVD-2015-1723
Updated
2026-11-03
GitHub AdvisoriesGHSA-j7c8-7vgp-wfmc No score

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7...

Movable Type Pro, Open Source, and Advanced before 5.2.12 and Pro and Advanced 6.0.x before 6.0.7 does not properly use the Perl Storable::thaw function, which allows remote attackers to include and execute arbitrary local Perl files and possibly execute arbitrary code via unspecified vectors.

Record
GHSA-j7c8-7vgp-wfmc
Weakness
CWE-74
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
movabletype-opensource
Debian:7
before 5.1.4+dfsg-4+deb7u2, plus listed versions
5.1.4+dfsg-45.1.4+dfsg-4+deb7u1
5.1.4+dfsg-4+deb7u2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBSixApart MovableType < 5.2.12 - Storable Perl Code Execution (Metasploit)2015-02-11
MetasploitSixApart MovableType Storable Perl Code Execution2015-02-11
PoC in GitHublightsey/cve-2015-15922015-04-10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1592 is a high vulnerability (CVSS 7.5) in Sixapart Movable Type, published February 19, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 74.8%, the 99th percentile. Fixed in movabletype-opensource 5.1.4+dfsg-4+deb7u2.

References

MoveEnter Open