Every CVE Search/ Get API key

CVE-2015-1828

http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

5.9 MediumFix available

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.52%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.9

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
CVE-2015-1828
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
CVE-2015-1828
Updated
2026-11-02
EUVDEUVD-2018-0172 No score

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
EUVD-2018-0172
Updated
2026-11-03
GitHub AdvisoriesGHSA-6wpv-cj6x-v3jw 5.9

http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

The Ruby http gem before 0.6.4 and 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
GHSA-6wpv-cj6x-v3jw
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 5.9

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
CVE-2015-1828
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2015-1828 5.9

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
DEBIAN-CVE-2015-1828
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-6wpv-cj6x-v3jw 5.9

http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

The Ruby http gem before 0.6.4 and 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
GHSA-6wpv-cj6x-v3jw
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVUBUNTU-CVE-2015-1828 5.9

The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.

Record
UBUNTU-CVE-2015-1828
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
http
RubyGems
0.7.0 up to 0.7.3
0.7.3
http
RubyGems
before 0.6.4
0.6.4
ruby-http
Debian:12
before 1.0.2-2
1.0.2-2
ruby-http
Debian:13
before 1.0.2-2
1.0.2-2
ruby-http
Debian:14
before 1.0.2-2
1.0.2-2
http
RubyGems
0.7.0 up to 0.7.3, plus listed versions
0.7.10.7.2
0.7.3
http
RubyGems
before 0.6.4, plus listed versions
0.0.00.0.10.0.20.1.00.2.0
Show 11 moreShow less
0.3.00.4.00.5.00.5.0.pre0.5.0.pre20.5.10.6.00.6.0.pre0.6.10.6.20.6.3
0.6.4

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-1828 is a medium vulnerability (CVSS 5.9) in Http.rb Project Http.rb, published October 6, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in http 0.7.3.

References

Show 6 moreShow less
MoveEnter Open