CVE-2015-1866
ember-source vulnerable to Cross-site Scripting
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
- Record
CVE-2015-1866- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
- Record
CVE-2015-1866- Updated
- 2026-11-02
EUVDEUVD-2018-0414 No score
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
- Record
EUVD-2018-0414- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mp78-r56v-45qc
6.1
ember-source vulnerable to Cross-site Scripting
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
- Record
GHSA-mp78-r56v-45qc- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-mp78-r56v-45qc
6.1
ember-source vulnerable to Cross-site Scripting
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
- Record
GHSA-mp78-r56v-45qc- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ember-sourceRubyGems |
1.10.0 to 1.10.0 | 1.10.1 |
ember-sourceRubyGems |
1.11.0 up to 1.11.2 | 1.11.2 |
ember-sourceRubyGems |
1.10.0 up to 1.10.1 | 1.10.1 |
ember-sourceRubyGems |
1.11.0 up to 1.11.2, plus listed versions 1.11.0.11.11.1 |
1.11.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-1866 is a medium vulnerability (CVSS 6.1) in Emberjs Ember.js, published September 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in ember-source 1.10.1.
References
emberjs.com/blog/2015/04/14/security-and-bugfix-releases-ember-1-10-1-1-11-2-1-11-3.html
openwall.com/lists/oss-security/2015/04/14/11
securityfocus.com/bid/74185
nvd.nist.gov/vuln/detail/CVE-2015-1866
web.archive.org/web/20200228155301/http://www.securityfocus.com/bid/74185
github.com/rubysec/ruby-advisory-db/blob/master/gems/ember-source/CVE-2015-1866.yml
groups.google.com/forum
github.com/advisories/GHSA-mp78-r56v-45qc
github.com/Acidburn0zzz/ember.js