Every CVE Search/ Get API key

CVE-2015-2047

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39,...

2.6 LowFix available

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39, and 4.6.0 through 4.6.18, when configured for the frontend, allows remote attackers to bypass authentication via a password that is casted to an empty value.

Exploit likelihood

1.52%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39, and 4.6.0 through 4.6.18, when configured for the frontend, allows remote attackers to bypass authentication via a password that is casted to an empty value.

Record
CVE-2015-2047
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:P/A:N
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39, and 4.6.0 through 4.6.18, when configured for the frontend, allows remote attackers to bypass authentication via a password that is casted to an empty value.

Record
CVE-2015-2047
Updated
2026-11-02
EUVDEUVD-2015-2160 No score

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39, and 4.6.0 through 4.6.18, when configured for the frontend, allows remote attackers to bypass authentication via a password that is casted to an empty value.

Record
EUVD-2015-2160
Updated
2026-11-03
GitHub AdvisoriesGHSA-8545-g96p-q9hh No score

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39,...

The rsaauth extension in TYPO3 4.3.0 through 4.3.14, 4.4.0 through 4.4.15, 4.5.0 through 4.5.39, and 4.6.0 through 4.6.18, when configured for the frontend, allows remote attackers to bypass authentication via a password that is casted to an empty value.

Record
GHSA-8545-g96p-q9hh
Weakness
CWE-287
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3-src
Debian:7
before 4.5.19+dfsg1-5+wheezy4, plus listed versions
4.5.19+dfsg1-54.5.19+dfsg1-5+wheezy14.5.19+dfsg1-5+wheezy24.5.19+dfsg1-5+wheezy3
4.5.19+dfsg1-5+wheezy4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2047 is a low vulnerability (CVSS 2.6) in Typo3, published February 21, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in typo3-src 4.5.19+dfsg1-5+wheezy4.

References

Show 4 moreShow less
MoveEnter Open