CVE-2015-2060
cabextract before 1.6 does not properly check for leading slashes when extracting files, which...
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
CVE-2015-2060- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
CVE-2015-2060- Updated
- 2026-11-02
EUVDEUVD-2015-2173 No score
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
EUVD-2015-2173- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-frjv-h9wg-233r No score
cabextract before 1.6 does not properly check for leading slashes when extracting files, which...
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
GHSA-frjv-h9wg-233r- Updated
- 2026-11-02
OSV
5.3
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
CVE-2015-2060- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-2060
5.3
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
DEBIAN-CVE-2015-2060- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-2060
5.3
cabextract before 1.6 does not properly check for leading slashes when extracting files, which allows remote attackers to conduct absolute directory traversal attacks via a malformed UTF-8 character that is changed to a UTF-8 encoded slash.
- Record
UBUNTU-CVE-2015-2060- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2015-0086 No score
Updated cabextract packages fix CVE-2015-2060
A directory traversal issue in cabextract allows writing to locations outside of the current working directory, when extracting a crafted cab file that encodes the filenames in a certain manner (CVE-2015-2060).
- Record
MGASA-2015-0086- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cabextractDebian:12 |
before 1.6-1 | 1.6-1 |
cabextractDebian:13 |
before 1.6-1 | 1.6-1 |
cabextractDebian:14 |
before 1.6-1 | 1.6-1 |
cabextractMageia:4 |
before 1.5-1.1.mga4 | 1.5-1.1.mga4 |
cabextractUbuntu:Pro:14.04:LTS |
before 1.4-4ubuntu0.1~esm1, plus listed versions 1.4-4 |
1.4-4ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-2060 is a medium vulnerability (CVSS 5.3) in Cabextract Project Cabextract, published February 26, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in cabextract 1.6-1.
References
openwall.com/lists/oss-security/2015/02/18/3
openwall.com/lists/oss-security/2015/02/23/16
openwall.com/lists/oss-security/2015/02/23/24
cabextract.org.uk
lists.fedoraproject.org/pipermail/package-announce/2015-March/151147.html
lists.fedoraproject.org/pipermail/package-announce/2015-March/151145.html
Show 8 moreShow less
mandriva.com/security/advisories?name=MDVSA-2015:064
nvd.nist.gov/vuln/detail/CVE-2015-2060
github.com/advisories/GHSA-frjv-h9wg-233r
security-tracker.debian.org/tracker/CVE-2015-2060
advisories.mageia.org/MGASA-2015-0086.html
bugs.mageia.org/show_bug.cgi?id=15318
ubuntu.com/security/CVE-2015-2060
cve.org/CVERecord?id=CVE-2015-2060