Every CVE Search/ Get API key

CVE-2015-2308

Symfony Vulnerable to PHP Eval Injection

6.8 MediumFix available

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Exploit likelihood

1.34%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Record
CVE-2015-2308
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Record
CVE-2015-2308
Updated
2026-11-02
EUVDEUVD-2022-2557 No score

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Record
EUVD-2022-2557
Updated
2026-11-03
GitHub AdvisoriesGHSA-5c58-w9xc-qcj9 No score

Symfony Vulnerable to PHP Eval Injection

Applications with ESI support (and SSI support as of Symfony 2.6) enabled and using the Symfony built-in reverse proxy (the `Symfony\Component\HttpKernel\HttpCache class) are vulnerable to PHP code injection; a malicious user can inject PHP code that will be executed by the server.

HttpCache uses eval() to execute files in its cache when they contain ESI tags (and only when ESI is enabled). The vulnerability comes from the fact that PHP allows contents of <script language="php"> tags to be executed (and this kind of PHP tags is always available regardless of the configuration), but there were not escaped before the evaluation.

A possible exploit comes from websites also vulnerable to Cross-Site Scripting as an attacker can successfully conduct a PHP code injection attack by passing such a tag in a user submitted variable (for which proper output escaping was not applied).

Record
GHSA-5c58-w9xc-qcj9
Weakness
CWE-94
Updated
2026-11-02
OSV No score

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Record
CVE-2015-2308
Updated
2026-11-02
OSVDEBIAN-CVE-2015-2308 No score

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Record
DEBIAN-CVE-2015-2308
Updated
2026-11-02
OSVGHSA-5c58-w9xc-qcj9 No score

Symfony Vulnerable to PHP Eval Injection

Applications with ESI support (and SSI support as of Symfony 2.6) enabled and using the Symfony built-in reverse proxy (the `Symfony\Component\HttpKernel\HttpCache class) are vulnerable to PHP code injection; a malicious user can inject PHP code that will be executed by the server.

HttpCache uses eval() to execute files in its cache when they contain ESI tags (and only when ESI is enabled). The vulnerability comes from the fact that PHP allows contents of <script language="php"> tags to be executed (and this kind of PHP tags is always available regardless of the configuration), but there were not escaped before the evaluation.

A possible exploit comes from websites also vulnerable to Cross-Site Scripting as an attacker can successfully conduct a PHP code injection attack by passing such a tag in a user submitted variable (for which proper output escaping was not applied).

Record
GHSA-5c58-w9xc-qcj9
Weakness
CWE-94
Updated
2026-11-02
OSVUBUNTU-CVE-2015-2308 No score

Eval injection vulnerability in the HttpCache class in HttpKernel in Symfony 2.x before 2.3.27, 2.4.x and 2.5.x before 2.5.11, and 2.6.x before 2.6.6 allows remote attackers to execute arbitrary PHP code via a language="php" attribute of a SCRIPT element.

Record
UBUNTU-CVE-2015-2308
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
symfony/symfony
Packagist
2.0.0 up to 2.3.27
2.3.27
symfony/symfony
Packagist
2.4.0 up to 2.5.11
2.5.11
symfony/symfony
Packagist
2.6.0 up to 2.6.6
2.6.6
symfony/http-kernel
Packagist
2.0.0 up to 2.3.27
2.3.27
symfony/http-kernel
Packagist
2.4.0 up to 2.5.11
2.5.11
symfony/http-kernel
Packagist
2.6.0 up to 2.6.6
2.6.6
symfony
Debian:12
before 2.3.21+dfsg-4
2.3.21+dfsg-4
symfony
Debian:13
before 2.3.21+dfsg-4
2.3.21+dfsg-4
symfony
Debian:14
before 2.3.21+dfsg-4
2.3.21+dfsg-4
symfony/symfony
Packagist
2.0.0 up to 2.3.27, plus listed versions
2.0.42.0.52.0.62.0.7v2.0.10
Show 45 moreShow less
v2.0.11v2.0.12v2.0.13v2.0.14v2.0.15v2.0.16v2.0.17v2.0.18v2.0.19v2.0.20v2.0.21v2.0.22v2.0.23v2.0.24v2.0.25v2.0.9v2.1.0v2.1.0-BETA1v2.1.0-BETA2v2.1.0-BETA3v2.1.0-BETA4v2.1.0-RC1v2.1.0-RC2v2.1.1v2.1.10v2.1.11v2.1.12v2.1.13v2.1.2v2.1.3v2.1.4v2.1.5v2.1.6v2.1.7v2.1.8v2.1.9v2.2.0v2.2.0-BETA1v2.2.0-BETA2v2.2.0-RC1v2.2.0-RC2v2.2.0-RC3v2.2.1v2.2.10v2.2.11
2.3.27
Show 5 moreShow less
Affected packages
PackageAffectedFixed
symfony/symfony
Packagist
2.4.0 up to 2.5.11, plus listed versions
v2.4.0v2.4.1v2.4.10v2.4.2v2.4.3
Show 20 moreShow less
v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-BETA1v2.5.0-BETA2v2.5.0-RC1v2.5.1v2.5.10v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9
2.5.11
symfony/symfony
Packagist
2.6.0 up to 2.6.6, plus listed versions
v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5
2.6.6
symfony/http-kernel
Packagist
2.0.0 up to 2.3.27, plus listed versions
2.0.42.0.52.0.62.0.7v2.0.10
Show 45 moreShow less
v2.0.12v2.0.13v2.0.14v2.0.15v2.0.16v2.0.17v2.0.18v2.0.19v2.0.20v2.0.21v2.0.22v2.0.23v2.0.24v2.0.25v2.0.9v2.1.0v2.1.1v2.1.10v2.1.11v2.1.12v2.1.13v2.1.2v2.1.3v2.1.4v2.1.5v2.1.6v2.1.7v2.1.8v2.1.9v2.2.0v2.2.1v2.2.10v2.2.11v2.2.2v2.2.3v2.2.4v2.2.5v2.2.6v2.2.7v2.2.8v2.2.9v2.3.0v2.3.1v2.3.10v2.3.11
2.3.27
symfony/http-kernel
Packagist
2.4.0 up to 2.5.11, plus listed versions
v2.4.0v2.4.1v2.4.10v2.4.2v2.4.3
Show 20 moreShow less
v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-BETA1v2.5.0-BETA2v2.5.0-RC1v2.5.1v2.5.10v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9
2.5.11
symfony/http-kernel
Packagist
2.6.0 up to 2.6.6, plus listed versions
v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5
2.6.6

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2308 is a medium vulnerability (CVSS 6.8) in Sensiolabs Symfony, published June 24, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.34%, the 71st percentile. Fixed in symfony/symfony 2.3.27.

References

Show 9 moreShow less
This page doesn't list everything

Left out here: 61 versions. The JSON record has them.

MoveEnter Open