Every CVE Search/ Get API key

CVE-2015-2775

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias,...

7.6 HighFix available

CVE-2015-2775 is a high vulnerability (CVSS 7.6) in Gnu Mailman, published April 1, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.91%, the 94th percentile. Fixed in mailman 1:2.1.13-6.

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

Exploit likelihood

7.91%Up 6.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.6

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

Record
CVE-2015-2775
CVSS 2.0
7.6 HighAV:N/AC:H/Au:N/C:C/I:C/A:C
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

Record
CVE-2015-2775
Updated
2026-11-02
EUVDEUVD-2015-2865 No score

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

Record
EUVD-2015-2865
Updated
2026-11-03
GitHub AdvisoriesGHSA-rhjr-qgg7-67wg No score

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias,...

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

Record
GHSA-rhjr-qgg7-67wg
Weakness
CWE-22
Updated
2026-11-02
OSVMGASA-2015-0205 No score

Updated mailman packages fix security vulnerabilities

Updated mailman packages fix security vulnerability:

A path traversal vulnerability was discovered in Mailman. Installations using a transport script (such as postfix-to-mailman.py) to interface with their MTA instead of static aliases were vulnerable to a path traversal attack. To successfully exploit this, an attacker needs write access on the local file system (CVE-2015-2775).

Record
MGASA-2015-0205
Updated
2026-11-02
OSVopenSUSE-SU-2024:10215-1 No score

mailman-2.1.23-1.2 on GA media

These are all security issues fixed in the mailman-2.1.23-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10215-1
Updated
2026-11-02
Show 4 moreShow less
OSVSUSE-SU-2018:4296-1 No score

Security update for mailman

This update for mailman fixes the following security vulnerabilities:

  • Fixed a XSS vulnerability and information leak in user options CGI, which could be used to execute arbitrary scripts in the user's browser via specially encoded URLs (bsc#1077358 CVE-2018-5950)
  • Fixed a directory traversal vulnerability in MTA transports when using the recommended Mailman Transport for Exim (bsc#925502 CVE-2015-2775)
  • Fixed a XSS vulnerability, which allowed malicious listowners to inject scripts into the listinfo pages (bsc#1099510 CVE-2018-0618)
  • Fixed arbitrary text injection vulnerability in several mailman CGIs (CVE-2018-13796 bsc#1101288)
  • Fixed a CSRF vulnerability on the user options page (CVE-2016-6893 bsc#995352)
Record
SUSE-SU-2018:4296-1
Updated
2026-11-02
OSVSUSE-SU-2019:13924-1 No score

Security update for mailman

This update for mailman fixes the following issues:

  • Fixed a XSS vulnerability and information leak in user options CGI, which could be used to execute arbitrary scripts in the user's browser via specially encoded URLs (bsc#1077358 CVE-2018-5950)
  • Fixed a directory traversal vulnerability in MTA transports when using the recommended Mailman Transport for Exim (bsc#925502 CVE-2015-2775)
  • Fixed a XSS vulnerability, which allowed malicious listowners to inject scripts into the listinfo pages (bsc#1099510 CVE-2018-0618)
  • Fixed arbitrary text injection vulnerability in several mailman CGIs (CVE-2018-13796 bsc#1101288)
  • Fixed a CSRF vulnerability on the user options page (CVE-2016-6893 bsc#995352)
Record
SUSE-SU-2019:13924-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-2775 No score

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

Record
UBUNTU-CVE-2015-2775
Updated
2026-11-02
OSVUSN-2558-1 No score

mailman vulnerability

It was discovered that Mailman incorrectly handled special characters in list names. A local attacker could use this issue to perform a path traversal attack and execute arbitrary code as the Mailman user.

Record
USN-2558-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mailman
Debian:6.0
before 1:2.1.13-6, plus listed versions
1:2.1.13-4.11:2.1.13-5
1:2.1.13-6
mailman
Debian:7
before 1:2.1.15-1+deb7u1, plus listed versions
1:2.1.15-1
1:2.1.15-1+deb7u1
mailman
Mageia:4
before 2.1.20-1.1.mga4
2.1.20-1.1.mga4
mailman
Red Hat:enterprise_linux:7::server
before 3:2.1.15-21.ael7b_1
3:2.1.15-21.ael7b_1
mailman-debuginfo
Red Hat:enterprise_linux:7::server
before 3:2.1.15-21.ael7b_1
3:2.1.15-21.ael7b_1
mailman
Red Hat:enterprise_linux:7::workstation
before 3:2.1.15-21.el7_1
3:2.1.15-21.el7_1
mailman-debuginfo
Red Hat:enterprise_linux:7::workstation
before 3:2.1.15-21.el7_1
3:2.1.15-21.el7_1
mailman
Red Hat:enterprise_linux:6::server
before 3:2.1.12-25.el6
3:2.1.12-25.el6
mailman-debuginfo
Red Hat:enterprise_linux:6::server
before 3:2.1.12-25.el6
3:2.1.12-25.el6
mailman
Red Hat:enterprise_linux:6::workstation
before 3:2.1.12-25.el6
3:2.1.12-25.el6
Show 20 moreShow less
Affected packages
PackageAffectedFixed
mailman-debuginfo
Red Hat:enterprise_linux:6::workstation
before 3:2.1.12-25.el6
3:2.1.12-25.el6
mailman
SUSE:OpenStack Cloud 7
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server 12-LTSS
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server 12 SP1-LTSS
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server 12 SP2-LTSS
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server 12 SP2-BCL
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server 12 SP3
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server 12 SP4
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Enterprise Storage 4
before 2.1.17-3.3.3
2.1.17-3.3.3
mailman
SUSE:Linux Enterprise Point of Sale 11 SP3
before 2.1.15-9.6.6.1
2.1.15-9.6.6.1
mailman
SUSE:Linux Enterprise Server 11 SP3-LTSS
before 2.1.15-9.6.6.1
2.1.15-9.6.6.1
mailman
SUSE:Linux Enterprise Server 11 SP3-TERADATA
before 2.1.15-9.6.6.1
2.1.15-9.6.6.1
mailman
SUSE:Linux Enterprise Server 11 SP4
before 2.1.15-9.6.6.1
2.1.15-9.6.6.1
mailman
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 2.1.15-9.6.6.1
2.1.15-9.6.6.1
mailman
Ubuntu:14.04:LTS
before 1:2.1.16-2ubuntu0.1, plus listed versions
1:2.1.16~rc2-11:2.1.16-11:2.1.16-2
1:2.1.16-2ubuntu0.1
mailman
openSUSE:Tumbleweed
before 2.1.23-1.2
2.1.23-1.2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 44 moreShow less
MoveEnter Open