CVE-2015-2793
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3...
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
- Record
CVE-2015-2793- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
- Record
CVE-2015-2793- Updated
- 2026-11-02
EUVDEUVD-2015-2882 No score
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
- Record
EUVD-2015-2882- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pc62-pw4x-v3r6 No score
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3...
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
- Record
GHSA-pc62-pw4x-v3r6- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
- Record
CVE-2015-2793- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-2793
6.1
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
- Record
DEBIAN-CVE-2015-2793- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-2793 is a medium vulnerability (CVSS 6.1) in Ikiwiki, published November 21, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in ikiwiki 3.20141016.2.
References
lists.fedoraproject.org/pipermail/package-announce/2015-May/157025.html
lists.fedoraproject.org/pipermail/package-announce/2015-May/157001.html
lists.fedoraproject.org/pipermail/package-announce/2015-May/157023.html
ikiwiki.info/bugs/XSS_Alert...__33____33____33__
bugzilla.redhat.com/show_bug.cgi?id=1207210
source.ikiwiki.branchable.com?p=source.git%3Ba=commitdiff%3Bh=18dfba868fe2fb9c64706b2123eb0b3a3ce66a77
Show 7 moreShow less
bugs.debian.org/cgi-bin/bugreport.cgi?bug=781483
openwall.com/lists/oss-security/2015/03/30/5
openwall.com/lists/oss-security/2015/03/31/1
nvd.nist.gov/vuln/detail/CVE-2015-2793
source.ikiwiki.branchable.com?p=source.git;a=commitdiff;h=18dfba868fe2fb9c64706b2123eb0b3a3ce66a77
github.com/advisories/GHSA-pc62-pw4x-v3r6
security-tracker.debian.org/tracker/CVE-2015-2793