CVE-2015-2940
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows...
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
6.8
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
CVE-2015-2940- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
CVE-2015-2940- Updated
- 2026-11-02
EUVDEUVD-2015-3025 No score
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
EUVD-2015-3025- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g77q-mpv6-8w22 No score
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows...
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
GHSA-g77q-mpv6-8w22- Weakness
- CWE-352
- Updated
- 2026-11-02
OSV No score
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
CVE-2015-2940- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-2940 No score
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
DEBIAN-CVE-2015-2940- Updated
- 2026-11-02
OSVMGASA-2015-0142 No score
Updated mediawiki packages fix security vulnerabilities
Updated mediawiki packages fix security vulnerabilities:
In MediaWiki before 1.23.9, one could circumvent the SVG MIME blacklist for embedded resources. This allowed an attacker to embed JavaScript in the SVG (CVE-2015-2931).
In MediaWiki before 1.23.9, the SVG filter to prevent injecting JavaScript using animate elements was incorrect (CVE-2015-2932).
In MediaWiki before 1.23.9, a stored XSS vulnerability exists due to the way attributes were expanded in MediaWiki's Html class, in combination with LanguageConverter substitutions (CVE-2015-2933).
In MediaWiki before 1.23.9, MediaWiki's SVG filtering could be bypassed with entity encoding under the Zend interpreter. This could be used to inject JavaScript (CVE-2015-2934).
In MediaWiki before 1.23.9, one could bypass the style filtering for SVG files to load external resources. This could violate the anonymity of users viewing the SVG (CVE-2015-2935).
In MediaWiki before 1.23.9, MediaWiki versions using PBKDF2 for password hashing (not the default for 1.23) are vulnerable to DoS attacks using extremely long passwords (CVE-2015-2936).
In MediaWiki before 1.23.9, MediaWiki is vulnerable to "Quadratic Blowup" DoS attacks, under both HHVM and Zend PHP (CVE-2015-2937).
In MediaWiki before 1.23.9, the MediaWiki feature allowing a user to preview another user's custom JavaScript could be abused for privilege escalation (CVE-2015-2938).
In MediaWiki before 1.23.9, function names were not sanitized in Lua error backtraces, which could lead to XSS (CVE-2015-2939).
In MediaWiki before 1.23.9, the CheckUser extension did not prevent CSRF attacks on the form allowing checkusers to look up sensitive information about other users. Since the use of CheckUser is logged, the CSRF could be abused to defame a trusted user or flood the logs with noise (CVE-2015-2940).
The mediawiki package has been updated to version 1.23.9, fixing these issues and other bugs.
- Record
MGASA-2015-0142- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-2940 No score
Cross-site request forgery (CSRF) vulnerability in the CheckUser extension for MediaWiki allows remote attackers to hijack the authentication of certain users for requests that retrieve sensitive user information via unspecified vectors.
- Record
UBUNTU-CVE-2015-2940- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediawikiDebian:12 |
before 1:1.19.20+dfsg-2.3 | 1:1.19.20+dfsg-2.3 |
mediawikiDebian:13 |
before 1:1.19.20+dfsg-2.3 | 1:1.19.20+dfsg-2.3 |
mediawikiDebian:14 |
before 1:1.19.20+dfsg-2.3 | 1:1.19.20+dfsg-2.3 |
mediawikiMageia:4 From an advisory covering 10 CVEs |
before 1.23.9-1.mga4 | 1.23.9-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-2940 is a medium vulnerability (CVSS 6.8) in Mediawiki Checkuser, published April 9, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in mediawiki 1:1.19.20+dfsg-2.3.
References
security.gentoo.org/glsa/201510-05
mandriva.com/security/advisories?name=MDVSA-2015:200
securityfocus.com/bid/73477
openwall.com/lists/oss-security/2015/04/07/3
openwall.com/lists/oss-security/2015/04/01/1
lists.wikimedia.org/pipermail/mediawiki-announce/2015-March/000175.html
Show 8 moreShow less
phabricator.wikimedia.org/T85858
nvd.nist.gov/vuln/detail/CVE-2015-2940
github.com/advisories/GHSA-g77q-mpv6-8w22
security-tracker.debian.org/tracker/CVE-2015-2940
advisories.mageia.org/MGASA-2015-0142.html
bugs.mageia.org/show_bug.cgi?id=15606
ubuntu.com/security/CVE-2015-2940
cve.org/CVERecord?id=CVE-2015-2940