CVE-2015-3178
Moodle cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
Exploit likelihood
What each source reports
NVD Score used
3.5
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
- Record
CVE-2015-3178- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
- Record
CVE-2015-3178- Updated
- 2026-11-02
EUVDEUVD-2022-3364 No score
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
- Record
EUVD-2022-3364- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9fmw-m4qx-6cq8 No score
Moodle cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
- Record
GHSA-9fmw-m4qx-6cq8- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-9fmw-m4qx-6cq8 No score
Moodle cross-site scripting (XSS) vulnerability
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
- Record
GHSA-9fmw-m4qx-6cq8- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVMGASA-2015-0229 No score
Updated moodle packages fix security vulnerabilities
Updated moodle package fixes security vulnerabilities:
In Moodle before 2.6.11, leaving gradebook feedback is a trusted action and such capabilities in other modules already have an XSS mask, 'mod/quiz:grade' was missing this flag (CVE-2015-3174).
In Moodle before 2.6.11, some error messages display a button to return to the previous page. Redirecting to non-local referer should not be allowed as it can potentially be used for phising (CVE-2015-3175).
In Moodle before 2.6.11, on sites with enabled self-registration, not registered users can retrieve fullname of registered users if they know their usernames (CVE-2015-3176).
In Moodle before 2.6.11, if a user who is not XSS-trusted attempts to insert a script as part of the input text, it will be cleaned when displayed on the Moodle website but may be displayed uncleaned in the external application because external_format_text() cleans and formats text incorrectly when returning it from Web Services (CVE-2015-3178).
In Moodle before 2.6.11, when self-registration is enabled and a user's account was suspended after creating the account but before actually confirming it, the user is still able to login when confirming their email, but only once (CVE-2015-3179).
In Moodle before 2.6.11, if a user is enrolled in the course but his enrollment is suspended, they can not access the course but still were able to see the course structure in the navigation block (CVE-2015-3180).
In Moodle before 2.6.11, users with the revoked capability 'moodle/user:manageownfiles' are still able to upload private files using a deprecated function in Web Services (CVE-2015-3181).
- Record
MGASA-2015-0229- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-3178 No score
Cross-site scripting (XSS) vulnerability in the external_format_text function in lib/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML into an external application via a crafted string that is visible to web services.
- Record
UBUNTU-CVE-2015-3178- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.6.11 | 2.6.11 |
moodle/moodlePackagist |
2.7.0 up to 2.7.8 | 2.7.8 |
moodle/moodlePackagist |
2.8.0 up to 2.8.6 | 2.8.6 |
moodle/moodlePackagist |
before 2.6.11, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 41 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9 |
2.6.11 |
moodle/moodlePackagist |
2.7.0 up to 2.7.8, plus listed versions v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7 |
2.7.8 |
moodle/moodlePackagist |
2.8.0 up to 2.8.6, plus listed versions v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5 |
2.8.6 |
moodleMageia:4 From an advisory covering 7 CVEs |
before 2.6.11-1.mga4 | 2.6.11-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3178 is a low vulnerability (CVSS 3.5) in Moodle, published May 18, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in moodle/moodle 2.6.11.
References
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49718
securitytracker.com/id/1032358
moodle.org/mod/forum/discuss.php?d=313685
securityfocus.com/bid/74726
openwall.com/lists/oss-security/2015/05/18/1
nvd.nist.gov/vuln/detail/CVE-2015-3178
Show 22 moreShow less
github.com/moodle/moodle/commit/28947c1d7d9c53781989b9da7ceb2cafdd144749
github.com/moodle/moodle/commit/2c7d13dba37aa0c850c62037b951efd6dc1b0f78
github.com/moodle/moodle/commit/77067fbb3a248ac2f1fa4b3c20e5b81f768940e5
github.com/moodle/moodle/commit/7f5bd0da0e25feb3b6da3908b6672a58af82e12f
github.com/moodle/moodle/commit/b4da1e0ae4f63ef0bb14b8bf5c0b86cd00f2af4b
github.com/moodle/moodle/commit/d62d36c657a5df45ee286722490abb7901381da6
web.archive.org/web/20200228054910/http://www.securityfocus.com/bid/74726
web.archive.org/web/20201201000000*/http://www.securitytracker.com/id/1032358
github.com/advisories/GHSA-9fmw-m4qx-6cq8
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0229.html
bugs.mageia.org/show_bug.cgi?id=15909
moodle.org/mod/forum/discuss.php?d=313681
moodle.org/mod/forum/discuss.php?d=313682
moodle.org/mod/forum/discuss.php?d=313683
moodle.org/mod/forum/discuss.php?d=313686
moodle.org/mod/forum/discuss.php?d=313687
moodle.org/mod/forum/discuss.php?d=313688
docs.moodle.org/dev/Moodle_2.6.11_release_notes
moodle.org/mod/forum/discuss.php?d=313322
ubuntu.com/security/CVE-2015-3178
cve.org/CVERecord?id=CVE-2015-3178