Every CVE Search/ Get API key

CVE-2015-3179

Moodle allows attackers to bypass intended login restrictions

3.5 LowFix available

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Exploit likelihood

1.52%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Record
CVE-2015-3179
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Record
CVE-2015-3179
Updated
2026-11-02
EUVDEUVD-2022-2418 No score

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Record
EUVD-2022-2418
Updated
2026-11-03
GitHub AdvisoriesGHSA-4ppg-2mx6-fqx9 No score

Moodle allows attackers to bypass intended login restrictions

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Record
GHSA-4ppg-2mx6-fqx9
Updated
2026-11-02
OSVGHSA-4ppg-2mx6-fqx9 No score

Moodle allows attackers to bypass intended login restrictions

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Record
GHSA-4ppg-2mx6-fqx9
Updated
2026-11-02
OSVMGASA-2015-0229 No score

Updated moodle packages fix security vulnerabilities

Updated moodle package fixes security vulnerabilities:

In Moodle before 2.6.11, leaving gradebook feedback is a trusted action and such capabilities in other modules already have an XSS mask, 'mod/quiz:grade' was missing this flag (CVE-2015-3174).

In Moodle before 2.6.11, some error messages display a button to return to the previous page. Redirecting to non-local referer should not be allowed as it can potentially be used for phising (CVE-2015-3175).

In Moodle before 2.6.11, on sites with enabled self-registration, not registered users can retrieve fullname of registered users if they know their usernames (CVE-2015-3176).

In Moodle before 2.6.11, if a user who is not XSS-trusted attempts to insert a script as part of the input text, it will be cleaned when displayed on the Moodle website but may be displayed uncleaned in the external application because external_format_text() cleans and formats text incorrectly when returning it from Web Services (CVE-2015-3178).

In Moodle before 2.6.11, when self-registration is enabled and a user's account was suspended after creating the account but before actually confirming it, the user is still able to login when confirming their email, but only once (CVE-2015-3179).

In Moodle before 2.6.11, if a user is enrolled in the course but his enrollment is suspended, they can not access the course but still were able to see the course structure in the navigation block (CVE-2015-3180).

In Moodle before 2.6.11, users with the revoked capability 'moodle/user:manageownfiles' are still able to upload private files using a deprecated function in Web Services (CVE-2015-3181).

Record
MGASA-2015-0229
Updated
2026-11-02
OSVUBUNTU-CVE-2015-3179 No score

login/confirm.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to bypass intended login restrictions by leveraging access to an unconfirmed suspended account.

Record
UBUNTU-CVE-2015-3179
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.6.11
2.6.11
moodle/moodle
Packagist
2.7.0 up to 2.7.8
2.7.8
moodle/moodle
Packagist
2.8.0 up to 2.8.6
2.8.6
moodle/moodle
Packagist
before 2.6.11, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 41 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9
2.6.11
moodle/moodle
Packagist
2.7.0 up to 2.7.8, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7
2.7.8
moodle/moodle
Packagist
2.8.0 up to 2.8.6, plus listed versions
v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5
2.8.6
moodle
Mageia:4
From an advisory covering 7 CVEs
before 2.6.11-1.mga4
2.6.11-1.mga4

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3179 is a low vulnerability (CVSS 3.5) in Moodle, published May 18, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in moodle/moodle 2.6.11.

References

Show 20 moreShow less
MoveEnter Open