CVE-2015-3180
Moodle allows attackers to obtain sensitive course-structure information
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
Exploit likelihood
What each source reports
NVD Score used
4.0
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
- Record
CVE-2015-3180- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
- Record
CVE-2015-3180- Updated
- 2026-11-02
EUVDEUVD-2022-2748 No score
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
- Record
EUVD-2022-2748- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-688p-pgj4-77hh No score
Moodle allows attackers to obtain sensitive course-structure information
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
- Record
GHSA-688p-pgj4-77hh- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-688p-pgj4-77hh No score
Moodle allows attackers to obtain sensitive course-structure information
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
- Record
GHSA-688p-pgj4-77hh- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVMGASA-2015-0229 No score
Updated moodle packages fix security vulnerabilities
Updated moodle package fixes security vulnerabilities:
In Moodle before 2.6.11, leaving gradebook feedback is a trusted action and such capabilities in other modules already have an XSS mask, 'mod/quiz:grade' was missing this flag (CVE-2015-3174).
In Moodle before 2.6.11, some error messages display a button to return to the previous page. Redirecting to non-local referer should not be allowed as it can potentially be used for phising (CVE-2015-3175).
In Moodle before 2.6.11, on sites with enabled self-registration, not registered users can retrieve fullname of registered users if they know their usernames (CVE-2015-3176).
In Moodle before 2.6.11, if a user who is not XSS-trusted attempts to insert a script as part of the input text, it will be cleaned when displayed on the Moodle website but may be displayed uncleaned in the external application because external_format_text() cleans and formats text incorrectly when returning it from Web Services (CVE-2015-3178).
In Moodle before 2.6.11, when self-registration is enabled and a user's account was suspended after creating the account but before actually confirming it, the user is still able to login when confirming their email, but only once (CVE-2015-3179).
In Moodle before 2.6.11, if a user is enrolled in the course but his enrollment is suspended, they can not access the course but still were able to see the course structure in the navigation block (CVE-2015-3180).
In Moodle before 2.6.11, users with the revoked capability 'moodle/user:manageownfiles' are still able to upload private files using a deprecated function in Web Services (CVE-2015-3181).
- Record
MGASA-2015-0229- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-3180 No score
lib/navigationlib.php in Moodle through 2.5.9, 2.6.x before 2.6.11, 2.7.x before 2.7.8, and 2.8.x before 2.8.6 allows remote authenticated users to obtain sensitive course-structure information by leveraging access to a student account with a suspended enrolment.
- Record
UBUNTU-CVE-2015-3180- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.6.11 | 2.6.11 |
moodle/moodlePackagist |
2.7.0 up to 2.7.8 | 2.7.8 |
moodle/moodlePackagist |
2.8.0 up to 2.8.6 | 2.8.6 |
moodle/moodlePackagist |
before 2.6.11, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 41 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9 |
2.6.11 |
moodle/moodlePackagist |
2.7.0 up to 2.7.8, plus listed versions v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7 |
2.7.8 |
moodle/moodlePackagist |
2.8.0 up to 2.8.6, plus listed versions v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5 |
2.8.6 |
moodleMageia:4 From an advisory covering 7 CVEs |
before 2.6.11-1.mga4 | 2.6.11-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3180 is a medium vulnerability (CVSS 4.0) in Moodle, published May 18, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in moodle/moodle 2.6.11.
References
moodle.org/mod/forum/discuss.php?d=313687
securityfocus.com/bid/74729
securitytracker.com/id/1032358
openwall.com/lists/oss-security/2015/05/18/1
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49788
nvd.nist.gov/vuln/detail/CVE-2015-3180
Show 20 moreShow less
github.com/moodle/moodle/commit/032f18c4a50d472cddd2cb52a627d19b75921f16
github.com/moodle/moodle/commit/271477f593c4acbb84c620015fad19f08282629e
github.com/moodle/moodle/commit/8b4568500b305f7ddedbca355b73ce34ea4afbc0
github.com/moodle/moodle/commit/b7d307e80761e1c5b310958223640055d23b83f6
web.archive.org/web/20200228054132/http://www.securityfocus.com/bid/74729
web.archive.org/web/20201030042703/http://www.securitytracker.com/id/1032358
github.com/advisories/GHSA-688p-pgj4-77hh
github.com/moodle/moodle
advisories.mageia.org/MGASA-2015-0229.html
bugs.mageia.org/show_bug.cgi?id=15909
moodle.org/mod/forum/discuss.php?d=313681
moodle.org/mod/forum/discuss.php?d=313682
moodle.org/mod/forum/discuss.php?d=313683
moodle.org/mod/forum/discuss.php?d=313685
moodle.org/mod/forum/discuss.php?d=313686
moodle.org/mod/forum/discuss.php?d=313688
docs.moodle.org/dev/Moodle_2.6.11_release_notes
moodle.org/mod/forum/discuss.php?d=313322
ubuntu.com/security/CVE-2015-3180
cve.org/CVERecord?id=CVE-2015-3180