CVE-2015-3188
Apache Storm remote code execution vulnerability
The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to execute arbitrary code via unspecified vectors.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to execute arbitrary code via unspecified vectors.
- Record
CVE-2015-3188- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to execute arbitrary code via unspecified vectors.
- Record
CVE-2015-3188- Updated
- 2026-11-02
EUVDEUVD-2022-3571 No score
The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to execute arbitrary code via unspecified vectors.
- Record
EUVD-2022-3571- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cg5h-q983-4rww
9.8
Apache Storm remote code execution vulnerability
The UI daemon in Apache Storm 0.10.0-beta allows remote users to run arbitrary code as the user running the web server. With kerberos authentication this could allow impersonation of arbitrary users on other systems, including HDFS and HBase.
- Record
GHSA-cg5h-q983-4rww- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-cg5h-q983-4rww
9.8
Apache Storm remote code execution vulnerability
The UI daemon in Apache Storm 0.10.0-beta allows remote users to run arbitrary code as the user running the web server. With kerberos authentication this could allow impersonation of arbitrary users on other systems, including HDFS and HBase.
- Record
GHSA-cg5h-q983-4rww- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.storm:stormMaven |
0.10.0-beta to 0.10.0-beta | 0.10.0-beta1 |
org.apache.storm:stormMaven |
0.10.0-beta up to 0.10.0-beta1 | 0.10.0-beta1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3188 is a critical vulnerability (CVSS 9.8) in Apache Storm, published January 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 14.4%, the 96th percentile. Fixed in org.apache.storm:storm 0.10.0-beta1.
References
securitytracker.com/id/1032695
securityfocus.com/archive/1/535804/100/0/threaded
packetstormsecurity.com/files/132417/Apache-Storm-0.10.0-beta-Code-Execution.html
nvd.nist.gov/vuln/detail/CVE-2015-3188
github.com/apache/storm/blob/v0.10.0-beta1/SECURITY.md
github.com/apache/storm/blob/v0.10.0-beta1/STORM-UI-REST-API.md
web.archive.org/web/20151014213052/http://www.securitytracker.com/id/1032695
web.archive.org/web/20171202122914/http://www.securityfocus.com/archive/1/535804/100/0/threaded
github.com/advisories/GHSA-cg5h-q983-4rww