Every CVE Search/ Get API key

CVE-2015-3200

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a...

7.5 HighFix available

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

9.91%Up 7.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
CVE-2015-3200
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-74
Updated
2026-11-02
CVE List No score

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
CVE-2015-3200
Updated
2026-11-02
EUVDEUVD-2015-3266 No score

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
EUVD-2015-3266
Updated
2026-11-03
GitHub AdvisoriesGHSA-fxx4-pv62-6956 7.5

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a...

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
GHSA-fxx4-pv62-6956
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-74
Updated
2026-11-02
OSV 7.5

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
CVE-2015-3200
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3200 7.5

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
DEBIAN-CVE-2015-3200
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2015-3200 7.5

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Record
UBUNTU-CVE-2015-3200
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2015-0338 No score

Updated lighttpd packages fix CVE-2015-3200 & other bugs

Updated lighttpd packages fix security vulnerability:

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character (CVE-2015-3200).

The lighttpd package has been updated to version 1.4.37, fixing this issue and several other bugs.

In the Mageia 4 package, improvements have been made to the logrotate configuration and systemd service, allowing graceful reloading of configuration files and proper re-opening of log files (mga#15948, mga#15980).

Record
MGASA-2015-0338
Updated
2026-11-02
OSVSUSE-SU-2017:0728-1 No score

Security update for lighttpd

This update for lighttpd fixes the following issues:

Security issues fixed:

  • CVE-2016-1000212: don't allow requests to set the HTTP_PROXY variable. As *CGI apps might pick it up and use it for outgoing requests (bsc#990847).
  • CVE-2015-3200: log injection via malformed base64 string in Authentication header (bsc#932286).

Bugfixes:

  • added su directive to logrotate file as the directory is owned by lighttpd. (bsc#981347)
  • fix out of bounds read in mod_scgi (debian#857255)
Record
SUSE-SU-2017:0728-1
Updated
2026-11-02
OSVSUSE-SU-2017:0731-1 No score

Security update for lighttpd

This update for lighttpd fixes the following issues:

Security issues fixed:

  • CVE-2016-1000212: Don't allow requests to set the HTTP_PROXY variable. As *CGI apps might pick it up and use it for outgoing requests. (bsc#990847)
  • CVE-2015-3200: Log injection via malformed base64 string in Authentication header. (bsc#932286)

Bug fixes:

  • Add su directive to logrotate file as the directory is owned by lighttpd. (bsc#981347)
  • Fix out of bounds read in mod_scgi.
Record
SUSE-SU-2017:0731-1
Updated
2026-11-02
OSVUSN-4775-1 No score

lighttpd vulnerabilities

It was discovered that Lighttpd did not properly sanitized the string used in basic HTTP authentication method. A remote attacker could use this to inject arbitrary log entries and maybe obtain sensitive information. This issue only affected Ubuntu 14.04 ESM and Ubuntu 16.04 ESM. (CVE-2015-3200)

It was discovered that Lighttpd did not properly sanitized the string used in alias. A remote attacker could use this to access the content of the directory above the alias and obtain sensitive information. (CVE-2018-19052)

Record
USN-4775-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lighttpd
Debian:12
before 1.4.37-1
1.4.37-1
lighttpd
Debian:13
before 1.4.37-1
1.4.37-1
lighttpd
Debian:14
before 1.4.37-1
1.4.37-1
lighttpd
Mageia:4
before 1.4.37-1.mga4
1.4.37-1.mga4
lighttpd
Mageia:5
before 1.4.37-1.mga5
1.4.37-1.mga5
lighttpd
SUSE:Linux Enterprise High Availability Extension 12 SP1
before 1.4.35-3.1
1.4.35-3.1
lighttpd
SUSE:Linux Enterprise High Availability Extension 12 SP2
before 1.4.35-3.1
1.4.35-3.1
lighttpd
SUSE:Linux Enterprise Server for SAP Applications 12
before 1.4.35-3.1
1.4.35-3.1
lighttpd
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 1.4.20-2.58.1
1.4.20-2.58.1
lighttpd
SUSE:Linux Enterprise High Availability Extension 11 SP4
before 1.4.20-2.58.1
1.4.20-2.58.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
lighttpd
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.4.20-2.58.1
1.4.20-2.58.1
lighttpd
Ubuntu:Pro:14.04:LTS
before 1.4.33-1+nmu2ubuntu2.1+esm1, plus listed versions
1.4.31-3ubuntu31.4.33-1ubuntu11.4.33-1+nmu2ubuntu11.4.33-1+nmu2ubuntu21.4.33-1+nmu2ubuntu2.1
1.4.33-1+nmu2ubuntu2.1+esm1
lighttpd
Ubuntu:Pro:16.04:LTS
before 1.4.35-4ubuntu2.1+esm1, plus listed versions
1.4.35-4ubuntu11.4.35-4ubuntu21.4.35-4ubuntu2.1
1.4.35-4ubuntu2.1+esm1
lighttpd
Ubuntu:Pro:18.04:LTS
before 1.4.45-1ubuntu3.18.04.1+esm1, plus listed versions
1.4.45-1ubuntu11.4.45-1ubuntu31.4.45-1ubuntu3+esm11.4.45-1ubuntu3.18.041.4.45-1ubuntu3.18.04+esm11.4.45-1ubuntu3.18.04.1
1.4.45-1ubuntu3.18.04.1+esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3200 is a high vulnerability (CVSS 7.5) in Lighttpd, published June 9, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.91%, the 95th percentile. Fixed in lighttpd 1.4.37-1.

References

Show 23 moreShow less
MoveEnter Open