CVE-2015-3204
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart)...
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart) via an IKEv1 packet with (1) unassigned bits set in the IPSEC DOI value or (2) the next payload value set to ISAKMP_NEXT_SAK.
Exploit likelihood
What each source reports
NVD Score used
5.0
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart) via an IKEv1 packet with (1) unassigned bits set in the IPSEC DOI value or (2) the next payload value set to ISAKMP_NEXT_SAK.
- Record
CVE-2015-3204- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart) via an IKEv1 packet with (1) unassigned bits set in the IPSEC DOI value or (2) the next payload value set to ISAKMP_NEXT_SAK.
- Record
CVE-2015-3204- Updated
- 2026-11-02
EUVDEUVD-2015-3270 No score
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart) via an IKEv1 packet with (1) unassigned bits set in the IPSEC DOI value or (2) the next payload value set to ISAKMP_NEXT_SAK.
- Record
EUVD-2015-3270- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-52gh-6xp3-9wpf No score
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart)...
libreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart) via an IKEv1 packet with (1) unassigned bits set in the IPSEC DOI value or (2) the next payload value set to ISAKMP_NEXT_SAK.
- Record
GHSA-52gh-6xp3-9wpf- Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libreswanRed Hat:enterprise_linux:7::client |
before 0:3.12-10.1.el7_1 | 0:3.12-10.1.el7_1 |
libreswan-debuginfoRed Hat:enterprise_linux:7::client |
before 0:3.12-10.1.el7_1 | 0:3.12-10.1.el7_1 |
libreswanRed Hat:enterprise_linux:7::server |
before 0:3.12-10.1.ael7b_1 | 0:3.12-10.1.ael7b_1 |
libreswan-debuginfoRed Hat:enterprise_linux:7::server |
before 0:3.12-10.1.ael7b_1 | 0:3.12-10.1.ael7b_1 |
libreswanRed Hat:enterprise_linux:7::workstation |
before 0:3.12-10.1.el7_1 | 0:3.12-10.1.el7_1 |
libreswan-debuginfoRed Hat:enterprise_linux:7::workstation |
before 0:3.12-10.1.el7_1 | 0:3.12-10.1.el7_1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3204 is a medium vulnerability (CVSS 5.0) in Libreswan, published July 1, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.60%, the 85th percentile. Fixed in libreswan 0:3.12-10.1.el7_1.
References
libreswan.org/security/CVE-2015-3204/CVE-2015-3204.txt
rhn.redhat.com/errata/RHSA-2015-1154.html
security.gentoo.org/glsa/201603-13
securityfocus.com/bid/75392
nvd.nist.gov/vuln/detail/CVE-2015-3204
access.redhat.com/errata/RHSA-2015:1154
Show 7 moreShow less
access.redhat.com/security/cve/CVE-2015-3204
bugzilla.redhat.com/show_bug.cgi?id=1223361
libreswan.org/security/CVE-2015-3204/CVE-2015-3204-libreswan.patch
github.com/advisories/GHSA-52gh-6xp3-9wpf
access.redhat.com/security/updates/classification
security.access.redhat.com/data/csaf/v2/advisories/2015/rhsa-2015_1154.json
cve.org/CVERecord?id=CVE-2015-3204