Every CVE Search/ Get API key

CVE-2015-3255

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in...

4.6 MediumFix available

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Exploit likelihood

0.38%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
CVE-2015-3255
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
CVE-2015-3255
Updated
2026-11-02
EUVDEUVD-2015-3308 No score

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
EUVD-2015-3308
Updated
2026-11-03
GitHub AdvisoriesGHSA-3hwj-36x6-3356 No score

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in...

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
GHSA-3hwj-36x6-3356
Updated
2026-11-02
OSV No score

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
CVE-2015-3255
Updated
2026-11-02
OSVDEBIAN-CVE-2015-3255 No score

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
DEBIAN-CVE-2015-3255
Updated
2026-11-02
Show 5 moreShow less
OSVMGASA-2015-0262 No score

Updated polkit package fixes security vulnerabilities

Local privilege escalation in polkit before 0.113 due to predictable authentication session cookie values (CVE-2015-4625).

Various memory corruption vulnerabilities in polkit before 0.113 in the use of the JavaScript interpreter, possibly leading to local privilege escalation (CVE-2015-3256).

Memory corruption vulnerability in polkit before 0.113 in handling duplicate action IDs, possibly leading to local privilege escalation (CVE-2015-3255).

Denial of service issue in polkit before 0.113 which allowed any local user to crash polkitd (CVE-2015-3218).

Record
MGASA-2015-0262
Updated
2026-11-02
OSVopenSUSE-SU-2024:10436-1 No score

libpolkit0-0.113-3.4 on GA media

These are all security issues fixed in the libpolkit0-0.113-3.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10436-1
Updated
2026-11-02
OSVSUSE-SU-2015:1838-1 No score

Security update for polkit

polkit was updated to the 0.113 release, fixing security issues and bugs.

Security issues fixed:

  • Fixes CVE-2015-4625, a local privilege escalation due to predictable authentication session cookie values. Thanks to Tavis Ormandy, Google Project Zero for reporting this issue. For the future, authentication agents are encouraged to use PolkitAgentSession instead of using the D-Bus agent response API directly. (bsc#935119)
  • Fixes CVE-2015-3256, various memory corruption vulnerabilities in use of the JavaScript interpreter, possibly leading to local privilege escalation. (bsc#943816)
  • Fixes CVE-2015-3255, a memory corruption vulnerability in handling duplicate action IDs, possibly leading to local privilege escalation. Thanks to Laurent Bigonville for reporting this issue. (bsc#939246)
  • Fixes CVE-2015-3218, which allowed any local user to crash polkitd. Thanks to Tavis Ormandy, Google Project Zero, for reporting this issue. (bsc#933922)

Other issues fixed:

  • On systemd-213 and later, the 'active' state is shared across all sessions of an user, instead of being tracked separately.
  • pkexec, when not given a program to execute, runs the users shell by default.
  • Fixed shutdown problems on powerpc64le (bsc#950114)
  • polkit had a memory leak (bsc#912889)
Record
SUSE-SU-2015:1838-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-3255 No score

The polkit_backend_action_pool_init function in polkitbackend/polkitbackendactionpool.c in PolicyKit (aka polkit) before 0.113 might allow local users to gain privileges via duplicate action IDs in action descriptions.

Record
UBUNTU-CVE-2015-3255
Updated
2026-11-02
OSVUSN-3717-1 No score

policykit-1 vulnerabilities

Tavis Ormandy discovered that PolicyKit incorrectly handled certain invalid object paths. A local attacker could possibly use this issue to cause PolicyKit to crash, resulting in a denial of service. This issue only affected Ubuntu 14.04 LTS. (CVE-2015-3218)

It was discovered that PolicyKit incorrectly handled certain duplicate action IDs. A local attacker could use this issue to cause PolicyKit to crash, resulting in a denial of service, or possibly escalate privileges. This issue only affected Ubuntu 14.04 LTS. (CVE-2015-3255)

Tavis Ormandy discovered that PolicyKit incorrectly handled duplicate cookie values. A local attacker could use this issue to cause PolicyKit to crash, resulting in a denial of service, or possibly escalate privileges. This issue only affected Ubuntu 14.04 LTS. (CVE-2015-4625)

Matthias Gerstner discovered that PolicyKit incorrectly checked users. A local attacker could possibly use this issue to cause authentication dialogs to show up for other users, leading to a denial of service or an information leak. (CVE-2018-1116)

Record
USN-3717-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
policykit-1
Debian:12
before 0.105-12
0.105-12
policykit-1
Debian:13
before 0.105-12
0.105-12
policykit-1
Debian:14
before 0.105-12
0.105-12
polkit
Mageia:4
before 0.113-1.mga4
0.113-1.mga4
polkit
Mageia:5
before 0.113-1.mga5
0.113-1.mga5
polkit
SUSE:Linux Enterprise Desktop 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Software Development Kit 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Server 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Server for SAP Applications 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Workstation Extension 12
before 0.113-4.1
0.113-4.1
policykit-1
Ubuntu:14.04:LTS
before 0.105-4ubuntu3.14.04.2, plus listed versions
0.105-3ubuntu30.105-4ubuntu10.105-4ubuntu20.105-4ubuntu2.14.04.10.105-4ubuntu3.14.04.1
0.105-4ubuntu3.14.04.2
policykit-1
Ubuntu:16.04:LTS
before 0.105-14.1ubuntu0.1, plus listed versions
0.105-11ubuntu20.105-130.105-13ubuntu10.105-140.105-14.1
0.105-14.1ubuntu0.1
policykit-1
Ubuntu:18.04:LTS
before 0.105-20ubuntu0.18.04.1, plus listed versions
0.105-180.105-20
0.105-20ubuntu0.18.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3255 is a medium vulnerability (CVSS 4.6) in Polkit Project Polkit, published July 5, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in policykit-1 0.105-12.

References

Show 28 moreShow less
MoveEnter Open