Every CVE Search/ Get API key

CVE-2015-3272

Moodle open redirect vulnerability

7.4 HighFix available

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.85%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.4

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Record
CVE-2015-3272
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Record
CVE-2015-3272
Updated
2026-11-02
EUVDEUVD-2022-1995 No score

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Record
EUVD-2022-1995
Updated
2026-11-03
GitHub AdvisoriesGHSA-2hw2-h3mf-c2j9 7.4

Moodle open redirect vulnerability

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Record
GHSA-2hw2-h3mf-c2j9
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-2hw2-h3mf-c2j9 7.4

Moodle open redirect vulnerability

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Record
GHSA-2hw2-h3mf-c2j9
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2015-3272 7.4

Open redirect vulnerability in the clean_param function in lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via vectors involving an HTTP Referer header that has a substring match with a local URL.

Record
UBUNTU-CVE-2015-3272
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2015-0302 No score

Updated moodle package fixes security vulnerabilities

In Moodle before 2.8.7, phishing is possible when redirecting to external site using referer headers in error messages (CVE-2015-3272).

In Moodle before 2.8.7, several web services returning user information did not clean text in text custom profile fields, leading to possible XSS (CVE-2015-3274).

In Moodle before 2.8.7, possible Javascript injection was discovered in the SCORM module (CVE-2015-3275).

As Moodle 2.6 is no longer supported, users of this package on Mageia 4 are advised to migrate to Mageia 5.

Record
MGASA-2015-0302
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.7.0 up to 2.7.9
2.7.9
moodle/moodle
Packagist
2.8.0 up to 2.8.7
2.8.7
moodle/moodle
Packagist
2.9.0 up to 2.9.1
2.9.1
moodle/moodle
Packagist
2.7.0 up to 2.7.9, plus listed versions
v2.7.0v2.7.1v2.7.2v2.7.3v2.7.4
Show 4 moreShow less
v2.7.5v2.7.6v2.7.7v2.7.8
2.7.9
moodle/moodle
Packagist
2.8.0 up to 2.8.7, plus listed versions
v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.8.6
2.8.7
moodle/moodle
Packagist
2.9.0 up to 2.9.1, plus listed versions
v2.9.0
2.9.1
moodle
Mageia:5
From an advisory covering 3 CVEs
before 2.8.7-1.mga5
2.8.7-1.mga5

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3272 is a high vulnerability (CVSS 7.4) in Moodle, published August 3, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.85%, the 79th percentile. Fixed in moodle/moodle 2.7.9.

References

Show 14 moreShow less
MoveEnter Open