CVE-2015-3397
Yii Framework Cross-site Scripting Vulnerability
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
- Record
CVE-2015-3397- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
- Record
CVE-2015-3397- Updated
- 2026-11-02
EUVDEUVD-2022-5469 No score
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
- Record
EUVD-2022-5469- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w2xx-jp9f-gp8g No score
Yii Framework Cross-site Scripting Vulnerability
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
- Record
GHSA-w2xx-jp9f-gp8g- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-w2xx-jp9f-gp8g No score
Yii Framework Cross-site Scripting Vulnerability
Cross-site scripting (XSS) vulnerability in Yii Framework before 2.0.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to JSON, arrays, and Internet Explorer 6 or 7.
- Record
GHSA-w2xx-jp9f-gp8g- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yiisoft/yii2Packagist |
before 2.0.4 | 2.0.4 |
yiisoft/yii2Packagist |
before 2.0.4, plus listed versions 2.0.02.0.0-alpha2.0.0-beta2.0.0-rc2.0.12.0.22.0.3 |
2.0.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3397 is a medium vulnerability (CVSS 4.3) in Yiiframework, published May 14, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.38%, the 83rd percentile. Fixed in yiisoft/yii2 2.0.4.
References
securityfocus.com/bid/74663
yiiframework.com/news/86/yii-2-0-4-is-released
github.com/yiisoft/yii2/blob/2.0.4/framework/CHANGELOG.md
nvd.nist.gov/vuln/detail/CVE-2015-3397
web.archive.org/web/20210122155403/http://www.securityfocus.com/bid/74663
github.com/FriendsOfPHP/security-advisories/blob/master/yiisoft/yii2/CVE-2015-3397.yaml
github.com/advisories/GHSA-w2xx-jp9f-gp8g