CVE-2015-3542
PHPExcel XXE Vulnerability
8.7 HighFix available
PHPExcel XXE Vulnerability
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
What each source reports
GitHub Advisories Score usedGHSA-3m9x-2qfj-xvq4
8.7
PHPExcel XXE Vulnerability
PHPExcel XXE Vulnerability
- Record
GHSA-3m9x-2qfj-xvq4- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-611
- Updated
- 2026-11-02
OSVGHSA-3m9x-2qfj-xvq4
8.7
PHPExcel XXE Vulnerability
PHPExcel XXE Vulnerability
- Record
GHSA-3m9x-2qfj-xvq4- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-611
- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpoffice/phpexcelPackagist |
before 1.8.1 | 1.8.1 |
phpoffice/phpexcelPackagist |
before 1.8.1, plus listed versions 1.7.91.7.9-rc11.8.01.8.0rc11.8.0rc21.8.0rc31.8.0rc4 |
1.8.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | GitHub Advisories, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3542 is a high vulnerability (CVSS 8.7) in phpoffice/phpexcel, published November 7, 2024. No source lists public exploit code. Fixed in phpoffice/phpexcel 1.8.1.