Every CVE Search/ Get API key

CVE-2015-3727

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS...

6.8 MediumFix available

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.

Exploit likelihood

1.98%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.

Record
CVE-2015-3727
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.

Record
CVE-2015-3727
Updated
2026-11-02
EUVDEUVD-2015-3763 No score

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.

Record
EUVD-2015-3763
Updated
2026-11-03
GitHub AdvisoriesGHSA-7f26-wwp8-67rw No score

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS...

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.

Record
GHSA-7f26-wwp8-67rw
Updated
2026-11-02
OSVMGASA-2016-0116 No score

Updated webkit2 packages fix security vulnerability

The webkit2 package has been updated to version 2.10.9, fixing several security issues and other bugs.

Record
MGASA-2016-0116
Updated
2026-11-02
OSVMGASA-2016-0120 No score

Updated webkit packages fix security vulnerability

The webkit package has been updated to version 2.4.10, fixing several security issues and other bugs.

Record
MGASA-2016-0120
Updated
2026-11-02
OSVopenSUSE-SU-2024:10461-1 No score

libjavascriptcoregtk-1_0-0-2.4.11-3.3 on GA media

These are all security issues fixed in the libjavascriptcoregtk-1_0-0-2.4.11-3.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10461-1
Updated
2026-11-02
OSVUBUNTU-CVE-2015-3727 No score

WebKit in Apple Safari before 6.2.7, 7.x before 7.1.7, and 8.x before 8.0.7, as used in Apple iOS before 8.4 and other products, does not properly restrict rename operations on WebSQL tables, which allows remote attackers to access an arbitrary web site's database via a crafted web site.

Record
UBUNTU-CVE-2015-3727
Updated
2026-11-02
OSVUSN-2937-1 No score

webkitgtk vulnerabilities

A large number of security issues were discovered in the WebKitGTK+ Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

Record
USN-2937-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkit2
Mageia:5
From an advisory covering 106 CVEs
before 2.10.9-1.mga5
2.10.9-1.mga5
webkit
Mageia:5
From an advisory covering 27 CVEs
before 2.4.10-1.mga5
2.4.10-1.mga5
webkitgtk
Ubuntu:14.04:LTS
before 2.4.10-0ubuntu0.14.04.1, plus listed versions
2.2.1-2ubuntu22.3.2-1ubuntu22.3.2-1ubuntu32.3.2-1ubuntu42.3.2-1ubuntu5
Show 10 moreShow less
2.3.2-1ubuntu62.3.4-1ubuntu22.3.90-1ubuntu12.3.91-0ubuntu12.4.0-1ubuntu22.4.2-1ubuntu0.12.4.3-1ubuntu22.4.4-1~ubuntu12.4.7-1~ubuntu12.4.8-1ubuntu1~ubuntu14.04.1
2.4.10-0ubuntu0.14.04.1
webkitgtk
Ubuntu:16.04:LTS
before 2.4.10-0ubuntu1, plus listed versions
2.4.9-2ubuntu2
2.4.10-0ubuntu1
qtwebkit-opensource-src
Ubuntu:16.04:LTS
All versions, plus listed versions
5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1
None known
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
webkitgtk
Ubuntu:14.04:LTS
From an advisory covering 27 CVEs
before 2.4.10-0ubuntu0.14.04.1, plus listed versions
2.2.1-2ubuntu22.3.2-1ubuntu22.3.2-1ubuntu32.3.2-1ubuntu42.3.2-1ubuntu5
Show 10 moreShow less
2.3.2-1ubuntu62.3.4-1ubuntu22.3.90-1ubuntu12.3.91-0ubuntu12.4.0-1ubuntu22.4.2-1ubuntu0.12.4.3-1ubuntu22.4.4-1~ubuntu12.4.7-1~ubuntu12.4.8-1ubuntu1~ubuntu14.04.1
2.4.10-0ubuntu0.14.04.1
gtk3
openSUSE:Tumbleweed
From an advisory covering 38 CVEs
before 2.4.11-3.3
2.4.11-3.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3727 is a medium vulnerability (CVSS 6.8) in Apple Safari, published July 2, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.98%, the 80th percentile. Fixed in webkitgtk 2.4.10-0ubuntu0.14.04.1.

References

Show 93 moreShow less
MoveEnter Open