CVE-2015-3887
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain...
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain privileges via a Trojan horse libproxychains4.so library in the current working directory, which is referenced in the LD_PRELOAD path.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain privileges via a Trojan horse libproxychains4.so library in the current working directory, which is referenced in the LD_PRELOAD path.
- Record
CVE-2015-3887- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-426
- Updated
- 2026-11-02
CVE List No score
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain privileges via a Trojan horse libproxychains4.so library in the current working directory, which is referenced in the LD_PRELOAD path.
- Record
CVE-2015-3887- Updated
- 2026-11-02
EUVDEUVD-2015-3922 No score
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain privileges via a Trojan horse libproxychains4.so library in the current working directory, which is referenced in the LD_PRELOAD path.
- Record
EUVD-2015-3922- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f7w4-66vv-c7cf
7.8
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain...
Untrusted search path vulnerability in ProxyChains-NG before 4.9 allows local users to gain privileges via a Trojan horse libproxychains4.so library in the current working directory, which is referenced in the LD_PRELOAD path.
- Record
GHSA-f7w4-66vv-c7cf- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10468-1 No score
proxychains-ng-4.11-1.5 on GA media
These are all security issues fixed in the proxychains-ng-4.11-1.5 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10468-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
proxychains-ngopenSUSE:Tumbleweed |
before 4.11-1.5 | 4.11-1.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3887 is a high vulnerability (CVSS 7.8) in Proxychains-ng Project Proxychains-ng, published September 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.49%, the 42nd percentile. Fixed in proxychains-ng 4.11-1.5.
References
openwall.com/lists/oss-security/2015/05/13/11
github.com/rofl0r/proxychains-ng/commit/9ab7dbeb3baff67a51d0c5e71465c453be0890b5
bugzilla.redhat.com/show_bug.cgi?id=1147013
securityfocus.com/bid/74648
github.com/rofl0r/proxychains-ng/blob/v4.9/README
github.com/rofl0r/proxychains-ng/issues/60
nvd.nist.gov/vuln/detail/CVE-2015-3887
github.com/advisories/GHSA-f7w4-66vv-c7cf
suse.com/security/cve/CVE-2015-3887